Bug 431896 - cant run dhclient more than once even after ifdown
Summary: cant run dhclient more than once even after ifdown
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp   
(Show other bugs)
Version: 5.1
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-07 18:14 UTC by clive darra
Modified: 2008-02-14 11:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-09 03:36:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description clive darra 2008-02-07 18:14:09 UTC
Description of problem:
cant run dhclient more than once (even after ifdown)

Version-Release number of selected component (if applicable):

How reproducible:
everytime

Steps to Reproduce:
1. boot
2. dhclient
3. (optional) ifdown eth0
4. dhclient
  
Actual results:
dhclient(2919) is already running - exiting

Expected results:
refresh dhcp settings

Additional info:

Comment 1 David Cantrell 2008-02-09 03:36:33 UTC
If you run dhclient by hand, you have to stop it by hand.  ifdown will only stop
dhclient instances started by ifup because the PIDs are recorded.  You cannot
run more than one dhclient per interface at a time.  If you have a multihomed
host, you need to specify the interface name to run multiple instances per
interface:

dhclient eth0
dhclient eth1
... and so on

Comment 2 clive darra 2008-02-14 11:24:36 UTC
many thanks 

my fault entirely for distro hopping too much (ubuntu seem to work slightly
differently)


Note You need to log in before you can comment on or make changes to this bug.