Bug 431904 - AttributeError: 'iscsi' object has no attribute 'iscsidStarted'
AttributeError: 'iscsi' object has no attribute 'iscsidStarted'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
powerpc Linux
low Severity medium
: beta
: ---
Assigned To: Chris Lumens
James Laska
: Regression
: 433337 (view as bug list)
Depends On: 433276
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 13:41 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:32:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (67.17 KB, text/plain)
2008-02-07 13:41 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-02-07 13:41:23 EST
Description of problem:

Start graphical install (vnc) and attempt to add an iSCSI volume.  

Version-Release number of selected component (if applicable):

RHEL5.2-Server-20080207.nightly

How reproducible:
100% on ppc so far

Steps to Reproduce:
1. Boot installer 
2. Get to stage#2 disk partitioning screen
3. Select to add additional storage device
4. Select iSCSI, OK
5. Enter IP (192.168.33.219) and IQN (iqn.rhel5.ppc) and select OK
  
Actual results:

Traceback (most recent call first):
  File "/usr/lib/anaconda/iscsi.py", line 355, in addTarget
    if not self.iscsidStarted:
  File "/usr/lib/anaconda/iw/autopart_type.py", line 165, in addIscsiDrive
    self.anaconda.id.iscsi.addTarget(ip, port, user, pw, self.intf)
  File "/usr/lib/anaconda/iw/autopart_type.py", line 226, in addDrive
    rc = self.addIscsiDrive()
AttributeError: 'iscsi' object has no attribute 'iscsidStarted'

Expected results:

 - See the iSCSI volume(s) accessible with the supplied IQN in the list of
drives at the anaconda partitioning screen


Additional info:

 - marking as a regression from RHEL5.1
Comment 1 James Laska 2008-02-07 13:41:23 EST
Created attachment 294256 [details]
anacdump.txt
Comment 2 James Laska 2008-02-13 14:17:34 EST
RHEL5.2-Server-20080212.0/ppc

The VNC server is now running.
Please connect to ibm-sf2b-lp1.test.redhat.com:1 to begin the install...
Press <enter> for a shell
Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 938, in ?
    instClass.setInstallData(anaconda)
  File "/usr/lib/anaconda/kickstart.py", line 831, in setInstallData
    self.ksparser.readKickstart(self.file)
  File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 1151, in
readKickstart
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 719, in handleCommand
    self.handler.handlers[cmd](cmdArgs)
  File "/usr/lib/anaconda/kickstart.py", line 183, in doIscsi
    if self.id.iscsi.addTarget(target.ipaddr, target.port, target.user,
target.password):
  File "/usr/lib/anaconda/iscsi.py", line 363, in addTarget
    if not self.iscsidStarted:
AttributeError: 'iscsi' object has no attribute 'iscsidStarted'

Requesting beta-blocker ... iSCSI inside anaconda appears not usable in current
beta candidates.
Comment 4 Chris Lumens 2008-02-13 16:27:29 EST
Fixed in anaconda-11.1.2.101-1.
Comment 6 James Laska 2008-02-18 09:17:00 EST
No longer seeing this in RHEL5.2-Server-20080218.nightly
Comment 7 James Laska 2008-02-18 10:29:29 EST
correction, make that RHEL5.2-Server-20080217.nightly
Comment 8 Chris Lumens 2008-02-18 14:21:54 EST
*** Bug 433337 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2008-05-21 11:32:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.