Bug 431944 - "Join Game" doesn't work on Glest 3.0.0
"Join Game" doesn't work on Glest 3.0.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glest (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 17:45 EST by Edward Karavakis
Modified: 2008-02-27 08:41 EST (History)
0 users

See Also:
Fixed In Version: glest-3.0.0-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 08:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Karavakis 2008-02-07 17:45:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Glest-3.0.0 supports Multiplayer Network play over LAN/Internet.

Nothing appears when you press the "join game" button. No new screen appears to enter server's IP.

Version-Release number of selected component (if applicable):
glest-3.0.0-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Run glest-3.0.0
2. Press the "Join Game" button
3.

Actual Results:
Cannot join a network game. Nothing happens when pressing the "Join Game" button.

Expected Results:
Network play should work.

Additional info:
Comment 1 Edward Karavakis 2008-02-09 16:34:26 EST
started glest from the cli and pressed the 'join game' button:
# glest
Couldn't process event: Value not found in properties: ServerIp, loaded from:
glest.ini


There's no ServerIp whatsoever in the glest.ini file. Maybe because it's the
glest.ini from glest 2.x instead of 3.x ?
Comment 2 Fedora Update System 2008-02-15 02:35:15 EST
glest-3.0.0-3.fc8 has been submitted as an update for Fedora 8
Comment 3 Edward Karavakis 2008-02-15 09:32:13 EST
Today Glest version 3.1.0 has been released. This version contains several
improvements for the online component and a new menu background.

New features.

- In-game chat
- Main menu background model changed
- Server IPs are now stored in a file, and can be used later
- Network status key
- Map changes: Added 'Swamp of Sorrow' and 'Valley of Death', removed 'One on
One' and 'The Ruins'
- Balance changes

More information here:

http://www.glest.org/glest_board/viewtopic.php?t=3237
cheers :)
Comment 4 Aurelien Bompard 2008-02-15 10:32:52 EST
Yeah, I got that mail too :)
I'm just waiting for the guys to publish a source tarball. That's much better
than building from SVN IMHO, and they promised it'll happen soon ;o)

Thanks for the heads-up anyway
Comment 5 Fedora Update System 2008-02-15 21:11:40 EST
glest-3.0.0-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.