Bug 431966 - segfault in intlclock
segfault in intlclock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 22:57 EST by Dave Malcolm
Modified: 2008-02-21 14:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 14:43:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 511676 None None None Never

  None (edit)
Description Dave Malcolm 2008-02-07 22:57:04 EST
Version-Release number of selected component (if applicable):
gnome-panel-2.21.5-1.fc9
(F9 Alpha Live CD i686)

How reproducible:
100%

Steps to Reproduce:
1. Click on clock applet
2. Open "Locations" expander, click "Edit" button
3. Click on "Add" button in "Locations" tab
4. Untitled dialog appears, all fields have blank values, click on Find... button
5. Another untitled dialog appears, click on Find Next, then try typing in text
entry box
  
Actual results:
clock-applet crashes

Expected results:
Shouldn't crash.  (Not sure what all these dialogs ought to be doing, but I'll
open another bug about this)
Comment 1 Dave Malcolm 2008-02-07 23:07:34 EST
Don't need to click on Find Next at stage 5, typing in the text entry box
triggers it:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7f95710 (LWP 3560)]
0x00af11ed in gtk_tree_model_get_valist () from /usr/lib/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x00af11ed in gtk_tree_model_get_valist ()
   from /usr/lib/libgtk-x11-2.0.so.0
#1  0x00af1064 in gtk_tree_model_get () from /usr/lib/libgtk-x11-2.0.so.0
#2  0x08065d8b in g_cclosure_marshal_VOID__VOID ()
#3  0x08b8fb90 in ?? ()
#4  0xbfd1b9b4 in ?? ()
#5  0x00000000 in ?? ()
(corrupt stack?)
Comment 2 Matthias Clasen 2008-02-07 23:32:39 EST
Can't reproduce here with 2.21.90. Do you still see this ?
Comment 3 Jens Petersen 2008-02-20 18:55:47 EST
Looks fixed to me in current rawhide.

Note You need to log in before you can comment on or make changes to this bug.