Bug 432009 - More than one encrypted partition during install crashes before finish
More than one encrypted partition during install crashes before finish
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 07:56 EST by Mauricio Teixeira
Modified: 2008-02-20 11:15 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 11:15:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grubyDiskName error in the console (27.79 KB, image/png)
2008-02-08 07:56 EST, Mauricio Teixeira
no flags Details

  None (edit)
Description Mauricio Teixeira 2008-02-08 07:56:52 EST
I tried installing Fedora 9 Alpha from the publicly provided DVD. The
installation went fine with the default partitioning. Then I tried a new
partition scheme with various partitions and only /home encrypted, that worked
fine too.

When I tried a new partition scheme, having swap, root and home encrypted, I got
the error in the screen shot attached.

The error occurs at the end of installation, while "Installing bootloader".

Sorry if I could not copy the full bug report on the GTK window, but the test
install was run inside a VirtualBox machine, and I could not find a way to copy,
so I had to screen shot the tty.
Comment 1 Mauricio Teixeira 2008-02-08 07:56:52 EST
Created attachment 294349 [details]
grubyDiskName error in the console
Comment 2 Mauricio Teixeira 2008-02-08 07:58:53 EST
An addition, here is the full partition scheme:

/dev/sda1 = /boot 100MB
/dev/sda2 = / 5G
/dev/sda3 = swap 1G
/dev/sda5 = /home 2G
Comment 3 David Lehman 2008-02-20 11:15:37 EST
The problem is triggered by the use of an encrypted regular partition for the
root filesystem.

This should be fixed in rawhide once booty is rebuilt.

Note You need to log in before you can comment on or make changes to this bug.