Bug 432029 - Permissions on /etc/cups and /var/spool/cups/tmp
Permissions on /etc/cups and /var/spool/cups/tmp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 09:30 EST by Karel Volný
Modified: 2009-05-18 16:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* the /etc/cups and /var/spool/cups/tmp directories had different permissions in the RPM package than in the filesystem after installation. This is due to the CUPS scheduler correcting the permissions on start-up. This difference would cause the package to fail the rpm verify test. The permissions have been corrected in the RPM package and now match the defaults expected by the CUPS scheduler.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2008-02-08 09:30:24 EST
Description of problem:
The rpm verify test fails due to problem with permissions. CUPS changes 
permissions on some items to match its own defaults, however these differ from 
the permissions from the package.


Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.9.22

How reproducible:
always

Steps to Reproduce:
1. Install the cups package
2. # rpm -V cups

  
Actual results:
.M.......   /etc/cups
.M.......   /var/spool/cups/tmp


Expected results:
[no error output]

Additional info:
the permissions within the package as per spec are:
%dir %attr(0755,root,sys) /etc/cups
%dir %attr(1700,root,sys) /var/spool/cups/tmp

the permissions on the filesystem when cups is running:
# ls -ld /etc/cups
drwxrwxr-x  5 root sys 4096 Feb  7 11:02 /etc/cups
# ls -ld /var/spool/cups/tmp
drwxrwx--T  2 root sys 4096 Jan 24 10:17 /var/spool/cups/tmp
Comment 1 Tim Waugh 2008-02-08 09:49:14 EST
Those lines should probably read:

%dir %attr(0775,root,sys) /etc/cups
%dir %attr(1770,root,sys) /var/spool/cups/tmp

as cups-1.1.22rc1/scheduler/conf.c:497
  chmod(ServerRoot, 0775);
and conf.c:551:
    chmod(TempDir, 01770);
Comment 2 RHEL Product and Program Management 2008-10-31 12:36:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 Ruediger Landmann 2009-01-26 22:28:19 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* the /etc/cups and /var/spool/cups/tmp directories had different permissions in the RPM package than in the filesystem after installation. This is due to the CUPS scheduler correcting the permissions on start-up. This difference would cause the package to fail the rpm verify test. The permissions have been corrected in the RPM package and now match the defaults expected by the CUPS scheduler.
Comment 12 errata-xmlrpc 2009-05-18 16:21:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0989.html

Note You need to log in before you can comment on or make changes to this bug.