Bug 432110 - rubygems should require ruby-devel?
rubygems should require ruby-devel?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rubygems (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 16:26 EST by Christopher Beland
Modified: 2013-04-30 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 12:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2008-02-08 16:26:56 EST
I tried to use "gem" to install "mongrel", but I got the error "can't find
header files for ruby."  I installed the ruby-devel RPM, and the gem
installation works.  It looks like ruby-devel is required for proper rubygems
operation, but RPM did not complain about any missing ruby-devel RPM when I
installed rubygems.
Comment 1 David Lutterkort 2008-04-07 12:46:28 EDT
No, a non-devel package should never require a -devel package. The issue is that
rubygems is fundamentally broken when it comes to binary gems.

One way to work around that is to build those gems into rpm's (e.g., using gem2rpm)

mongrel is also packaged as an RPM; if you just install rubygem-mongrel, all
will be fine.

Note You need to log in before you can comment on or make changes to this bug.