Bug 432143 - --skip-broken doesn't
--skip-broken doesn't
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 432316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-08 20:43 EST by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 11:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-02-08 20:43:39 EST
yum-3.2.11-1.fc9.noarch

Loaded plugins: refresh-updatesd, tsflags
Running "init" handler for "tsflags" plugin
Yum Version: 3.2.11
COMMAND: yum -d5 --skip-broken upgrade 
Installroot: /
Reading Local RPMDB
Setting up Package Sacks
Running "postreposetup" handler for "tsflags" plugin
Setting up Upgrade Process
Building updates object
Resolving Dependencies
1202521341.77
--> Running transaction check
Checking deps for libdhcp-devel.x86_64 0-1.99.7-1.fc9 - None
Checking deps for system-config-firewall-tui.noarch 0-1.2.2-1.fc9 - None
---> Package e2fsprogs-libs.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-libs.x86_64 0-1.40.5-2.fc9 - u
Checking deps for libggz.x86_64 0-0.0.14-1.fc9 - None
Checking deps for e2fsprogs-devel.x86_64 0-1.40.5-1.fc9 - None
---> Package tomcat5-jsp-2.0-api.x86_64 0:5.5.26-1jpp.1.fc9 set to be updated
Checking deps for tomcat5-jsp-2.0-api.x86_64 0-5.5.26-1jpp.1.fc9 - u
looking for (u'tomcat5-servlet-2.4-api', u'EQ', (u'0', u'5.5.26',
u'1jpp.1.fc9')) as a requirement of tomcat5-jsp-2.0-api.x86_64
0-5.5.26-1jpp.1.fc9 - u
Checking deps for SDL_ttf.x86_64 0-2.0.9-3.fc8 - None
---> Package libksba.x86_64 0:1.0.2-4.fc9 set to be updated
Checking deps for libksba.x86_64 0-1.0.2-4.fc9 - u
Checking deps for gtk-nodoka-engine.x86_64 0-0.6.90.2-1.fc9 - None
Checking deps for pyparted.x86_64 0-1.8.9-4.fc9 - None
Checking deps for bzr.x86_64 0-1.1-1.fc9 - None
Checking deps for libdhcp.x86_64 0-1.99.7-1.fc9 - None
---> Package gc.x86_64 0:7.0-7.fc9 set to be updated
Checking deps for gc.x86_64 0-7.0-7.fc9 - u
Checking deps for e2fsprogs.x86_64 0-1.40.5-1.fc9 - None
---> Package SDL_image.x86_64 0:1.2.6-6.fc9 set to be updated
Checking deps for SDL_image.x86_64 0-1.2.6-6.fc9 - u
---> Package system-config-firewall.noarch 0:1.2.3-1.fc9 set to be updated
Checking deps for system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'usermode', u'GE', (u'0', u'1.94.1', None)) as a requirement of
system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'system-config-firewall-tui', u'EQ', (u'0', u'1.2.3', u'1.fc9'))
as a requirement of system-config-firewall.noarch 0-1.2.3-1.fc9 - u
system-config-firewall-1.2.3-1.fc9.noarch requires: usermode >= 1.94.1
--> Processing Dependency: usermode >= 1.94.1 for package: system-config-firewall
Searching pkgSack for dep: usermode
Potential match for usermode from usermode-1.94-1.fc9.i386
Potential match for usermode from usermode-1.94-1.fc9.x86_64
Checking deps for SDL_mixer.x86_64 0-1.2.8-6.fc9 - None
Checking deps for tomcat5-servlet-2.4-api.x86_64 0-5.5.25-3jpp.1.fc9 - None
Checking deps for libksba.x86_64 0-1.0.2-3.fc8 - None
---> Package SDL_ttf.x86_64 0:2.0.9-4.fc9 set to be updated
Checking deps for SDL_ttf.x86_64 0-2.0.9-4.fc9 - u
---> Package libdc1394.x86_64 0:2.0.1-4.fc9 set to be updated
Checking deps for libdc1394.x86_64 0-2.0.1-4.fc9 - u
---> Package libdhcp-devel.x86_64 0:1.99.7-2.fc9 set to be updated
Checking deps for libdhcp-devel.x86_64 0-1.99.7-2.fc9 - u
looking for (u'libdhcp', u'EQ', (u'0', u'1.99.7', u'2.fc9')) as a requirement of
libdhcp-devel.x86_64 0-1.99.7-2.fc9 - u
Checking deps for pygpgme.x86_64 0-0.1-7.fc9 - None
---> Package system-config-firewall-tui.noarch 0:1.2.3-1.fc9 set to be updated
Checking deps for system-config-firewall-tui.noarch 0-1.2.3-1.fc9 - u
---> Package e2fsprogs-devel.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-devel.x86_64 0-1.40.5-2.fc9 - u
looking for (u'e2fsprogs-libs', u'EQ', (u'0', u'1.40.5', u'2.fc9')) as a
requirement of e2fsprogs-devel.x86_64 0-1.40.5-2.fc9 - u
---> Package e2fsprogs-libs.i386 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-libs.i386 0-1.40.5-2.fc9 - u
Checking deps for e2fsprogs-libs.i386 0-1.40.5-1.fc9 - None
Checking deps for e2fsprogs-libs.x86_64 0-1.40.5-1.fc9 - None
---> Package SDL_mixer.x86_64 0:1.2.8-7.fc9 set to be updated
Checking deps for SDL_mixer.x86_64 0-1.2.8-7.fc9 - u
Checking deps for ilmbase.x86_64 0-1.0.1-1.fc9 - None
---> Package tomcat5-servlet-2.4-api.x86_64 0:5.5.26-1jpp.1.fc9 set to be updated
Checking deps for tomcat5-servlet-2.4-api.x86_64 0-5.5.26-1jpp.1.fc9 - u
---> Package gtk-nodoka-engine.x86_64 0:0.6.90.2-2.fc9 set to be updated
Checking deps for gtk-nodoka-engine.x86_64 0-0.6.90.2-2.fc9 - u
looking for (u'gtk2', u'GE', (u'0', u'2.12.7', None)) as a requirement of
gtk-nodoka-engine.x86_64 0-0.6.90.2-2.fc9 - u
Checking deps for SDL_image.x86_64 0-1.2.6-5.fc9 - None
Checking deps for libmpcdec.x86_64 0-1.2.6-3.fc8 - None
Checking deps for system-config-firewall.noarch 0-1.2.2-1.fc9 - None
---> Package pyparted.x86_64 0:1.8.9-5.fc9 set to be updated
Checking deps for pyparted.x86_64 0-1.8.9-5.fc9 - u
Checking deps for libdc1394.x86_64 0-2.0.1-3.fc9 - None
---> Package pygpgme.x86_64 0:0.1-8.fc9 set to be updated
Checking deps for pygpgme.x86_64 0-0.1-8.fc9 - u
---> Package e2fsprogs.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs.x86_64 0-1.40.5-2.fc9 - u
looking for (u'e2fsprogs-libs', u'EQ', (u'0', u'1.40.5', u'2.fc9')) as a
requirement of e2fsprogs.x86_64 0-1.40.5-2.fc9 - u
---> Package libmpcdec.x86_64 0:1.2.6-4.fc9 set to be updated
Checking deps for libmpcdec.x86_64 0-1.2.6-4.fc9 - u
Checking deps for tomcat5-jsp-2.0-api.x86_64 0-5.5.25-3jpp.1.fc9 - None
---> Package libggz.x86_64 0:0.0.14-3.fc9 set to be updated
Checking deps for libggz.x86_64 0-0.0.14-3.fc9 - u
---> Package libdhcp.x86_64 0:1.99.7-2.fc9 set to be updated
Checking deps for libdhcp.x86_64 0-1.99.7-2.fc9 - u
---> Package bzr.x86_64 0:1.1-2.fc9 set to be updated
Checking deps for bzr.x86_64 0-1.1-2.fc9 - u
Checking deps for gc.x86_64 0-7.0-6.fc8 - None
---> Package ilmbase.x86_64 0:1.0.1-2.fc9 set to be updated
Checking deps for ilmbase.x86_64 0-1.0.1-2.fc9 - u
looking for (u'libstdc++.so.6(GLIBCXX_3.4.9)(64bit)', None, (None, None, None))
as a requirement of ilmbase.x86_64 0-1.0.1-2.fc9 - u
--> Finished Dependency Resolution
Dependency Process ending
system-config-firewall-1.2.3-1.fc9.noarch from dfoo has depsolving problems
  --> Missing Dependency: usermode >= 1.94.1 is needed by package
system-config-firewall-1.2.3-1.fc9.noarch (dfoo)
Skip-broken round 1
--> Running transaction check
Checking deps for libdhcp-devel.x86_64 0-1.99.7-1.fc9 - None
Checking deps for system-config-firewall-tui.noarch 0-1.2.2-1.fc9 - None
system-config-firewall-1.2.2-1.fc9.noarch requires: system-config-firewall-tui =
1.2.2-1.fc9
--> Processing Dependency: system-config-firewall-tui = 1.2.2-1.fc9 for package:
system-config-firewall
Potential Provider: system-config-firewall-tui.noarch 0:1.2.2-1.fc9
Mode is u for provider of system-config-firewall-tui = 1.2.2-1.fc9:
system-config-firewall-tui.noarch 0:1.2.2-1.fc9
Mode for pkg providing system-config-firewall-tui = 1.2.2-1.fc9: u
TSINFO: Updating system-config-firewall-1.2.3-1.fc9.noarch to resolve dep.
---> Package e2fsprogs-libs.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-libs.x86_64 0-1.40.5-2.fc9 - u
Checking deps for libggz.x86_64 0-0.0.14-1.fc9 - None
Checking deps for e2fsprogs-devel.x86_64 0-1.40.5-1.fc9 - None
---> Package tomcat5-jsp-2.0-api.x86_64 0:5.5.26-1jpp.1.fc9 set to be updated
Checking deps for tomcat5-jsp-2.0-api.x86_64 0-5.5.26-1jpp.1.fc9 - u
looking for (u'tomcat5-servlet-2.4-api', u'EQ', (u'0', u'5.5.26',
u'1jpp.1.fc9')) as a requirement of tomcat5-jsp-2.0-api.x86_64
0-5.5.26-1jpp.1.fc9 - u
Checking deps for SDL_ttf.x86_64 0-2.0.9-3.fc8 - None
---> Package libksba.x86_64 0:1.0.2-4.fc9 set to be updated
Checking deps for libksba.x86_64 0-1.0.2-4.fc9 - u
Checking deps for gtk-nodoka-engine.x86_64 0-0.6.90.2-1.fc9 - None
Checking deps for pyparted.x86_64 0-1.8.9-4.fc9 - None
Checking deps for bzr.x86_64 0-1.1-1.fc9 - None
Checking deps for libdhcp.x86_64 0-1.99.7-1.fc9 - None
---> Package gc.x86_64 0:7.0-7.fc9 set to be updated
Checking deps for gc.x86_64 0-7.0-7.fc9 - u
Checking deps for e2fsprogs.x86_64 0-1.40.5-1.fc9 - None
---> Package SDL_image.x86_64 0:1.2.6-6.fc9 set to be updated
Checking deps for SDL_image.x86_64 0-1.2.6-6.fc9 - u
Checking deps for SDL_mixer.x86_64 0-1.2.8-6.fc9 - None
Checking deps for tomcat5-servlet-2.4-api.x86_64 0-5.5.25-3jpp.1.fc9 - None
Checking deps for libksba.x86_64 0-1.0.2-3.fc8 - None
---> Package SDL_ttf.x86_64 0:2.0.9-4.fc9 set to be updated
Checking deps for SDL_ttf.x86_64 0-2.0.9-4.fc9 - u
---> Package libdc1394.x86_64 0:2.0.1-4.fc9 set to be updated
Checking deps for libdc1394.x86_64 0-2.0.1-4.fc9 - u
---> Package libdhcp-devel.x86_64 0:1.99.7-2.fc9 set to be updated
Checking deps for libdhcp-devel.x86_64 0-1.99.7-2.fc9 - u
looking for (u'libdhcp', u'EQ', (u'0', u'1.99.7', u'2.fc9')) as a requirement of
libdhcp-devel.x86_64 0-1.99.7-2.fc9 - u
Checking deps for pygpgme.x86_64 0-0.1-7.fc9 - None
---> Package system-config-firewall-tui.noarch 0:1.2.3-1.fc9 set to be updated
Checking deps for system-config-firewall-tui.noarch 0-1.2.3-1.fc9 - u
---> Package e2fsprogs-devel.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-devel.x86_64 0-1.40.5-2.fc9 - u
looking for (u'e2fsprogs-libs', u'EQ', (u'0', u'1.40.5', u'2.fc9')) as a
requirement of e2fsprogs-devel.x86_64 0-1.40.5-2.fc9 - u
---> Package e2fsprogs-libs.i386 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs-libs.i386 0-1.40.5-2.fc9 - u
Checking deps for e2fsprogs-libs.i386 0-1.40.5-1.fc9 - None
Checking deps for e2fsprogs-libs.x86_64 0-1.40.5-1.fc9 - None
---> Package SDL_mixer.x86_64 0:1.2.8-7.fc9 set to be updated
Checking deps for SDL_mixer.x86_64 0-1.2.8-7.fc9 - u
Checking deps for ilmbase.x86_64 0-1.0.1-1.fc9 - None
---> Package tomcat5-servlet-2.4-api.x86_64 0:5.5.26-1jpp.1.fc9 set to be updated
Checking deps for tomcat5-servlet-2.4-api.x86_64 0-5.5.26-1jpp.1.fc9 - u
---> Package gtk-nodoka-engine.x86_64 0:0.6.90.2-2.fc9 set to be updated
Checking deps for gtk-nodoka-engine.x86_64 0-0.6.90.2-2.fc9 - u
looking for (u'gtk2', u'GE', (u'0', u'2.12.7', None)) as a requirement of
gtk-nodoka-engine.x86_64 0-0.6.90.2-2.fc9 - u
Checking deps for SDL_image.x86_64 0-1.2.6-5.fc9 - None
Checking deps for libmpcdec.x86_64 0-1.2.6-3.fc8 - None
---> Package pyparted.x86_64 0:1.8.9-5.fc9 set to be updated
Checking deps for pyparted.x86_64 0-1.8.9-5.fc9 - u
Checking deps for libdc1394.x86_64 0-2.0.1-3.fc9 - None
---> Package pygpgme.x86_64 0:0.1-8.fc9 set to be updated
Checking deps for pygpgme.x86_64 0-0.1-8.fc9 - u
---> Package e2fsprogs.x86_64 0:1.40.5-2.fc9 set to be updated
Checking deps for e2fsprogs.x86_64 0-1.40.5-2.fc9 - u
looking for (u'e2fsprogs-libs', u'EQ', (u'0', u'1.40.5', u'2.fc9')) as a
requirement of e2fsprogs.x86_64 0-1.40.5-2.fc9 - u
---> Package libmpcdec.x86_64 0:1.2.6-4.fc9 set to be updated
Checking deps for libmpcdec.x86_64 0-1.2.6-4.fc9 - u
Checking deps for tomcat5-jsp-2.0-api.x86_64 0-5.5.25-3jpp.1.fc9 - None
---> Package libggz.x86_64 0:0.0.14-3.fc9 set to be updated
Checking deps for libggz.x86_64 0-0.0.14-3.fc9 - u
---> Package libdhcp.x86_64 0:1.99.7-2.fc9 set to be updated
Checking deps for libdhcp.x86_64 0-1.99.7-2.fc9 - u
---> Package bzr.x86_64 0:1.1-2.fc9 set to be updated
Checking deps for bzr.x86_64 0-1.1-2.fc9 - u
Checking deps for gc.x86_64 0-7.0-6.fc8 - None
---> Package ilmbase.x86_64 0:1.0.1-2.fc9 set to be updated
Checking deps for ilmbase.x86_64 0-1.0.1-2.fc9 - u
looking for (u'libstdc++.so.6(GLIBCXX_3.4.9)(64bit)', None, (None, None, None))
as a requirement of ilmbase.x86_64 0-1.0.1-2.fc9 - u
--> Running transaction check
---> Package system-config-firewall.noarch 0:1.2.3-1.fc9 set to be updated
Checking deps for system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'usermode', u'GE', (u'0', u'1.94.1', None)) as a requirement of
system-config-firewall.noarch 0-1.2.3-1.fc9 - u
looking for (u'system-config-firewall-tui', u'EQ', (u'0', u'1.2.3', u'1.fc9'))
as a requirement of system-config-firewall.noarch 0-1.2.3-1.fc9 - u
system-config-firewall-1.2.3-1.fc9.noarch requires: usermode >= 1.94.1
--> Processing Dependency: usermode >= 1.94.1 for package: system-config-firewall
Searching pkgSack for dep: usermode
Potential match for usermode from usermode-1.94-1.fc9.i386
Potential match for usermode from usermode-1.94-1.fc9.x86_64
Checking deps for system-config-firewall.noarch 0-1.2.2-1.fc9 - None
--> Finished Dependency Resolution
Dependency Process ending
system-config-firewall-1.2.3-1.fc9.noarch from development has depsolving problems
  --> Missing Dependency: usermode >= 1.94.1 is needed by package
system-config-firewall-1.2.3-1.fc9.noarch (development)
Skip-broken could not solve problems
Error: Missing Dependency: usermode >= 1.94.1 is needed by package
system-config-firewall-1.2.3-1.fc9.noarch (dfoo)
Comment 1 Andrew Farris 2008-02-11 04:05:18 EST
*** Bug 432316 has been marked as a duplicate of this bug. ***
Comment 2 Tim Lauridsen 2008-02-12 07:50:29 EST
Weird, cant reproduce it

[tim@hoth yum]$ sudo yum --enablerepo=development --skip-broken update
system-config-firewall-1.2.3-1.fc9.noarch thunderbird
Loaded plugins: aliases, refresh-updatesd
Excluding Packages from Fedora 8 - x86_64 - Test Updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package system-config-firewall.noarch 0:1.2.3-1.fc9 set to be updated
--> Processing Dependency: usermode >= 1.94.1 for package: system-config-firewall
--> Processing Dependency: system-config-firewall-tui = 1.2.3-1.fc9 for package:
system-config-firewall
---> Package thunderbird.x86_64 0:2.0.0.9-2.fc9 set to be updated
--> Running transaction check
---> Package system-config-firewall.noarch 0:1.2.3-1.fc9 set to be updated
--> Processing Dependency: usermode >= 1.94.1 for package: system-config-firewall
---> Package system-config-firewall-tui.noarch 0:1.2.3-1.fc9 set to be updated
--> Finished Dependency Resolution
system-config-firewall-1.2.3-1.fc9.noarch from development has depsolving problems
  --> Missing Dependency: usermode >= 1.94.1 is needed by package
system-config-firewall-1.2.3-1.fc9.noarch (development)
--> Running transaction check
---> Package thunderbird.x86_64 0:2.0.0.9-2.fc9 set to be updated
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    system-config-firewall-1.2.3-1.fc9.noarch from development
    system-config-firewall-tui-1.2.3-1.fc9.noarch from development

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 thunderbird             x86_64     2.0.0.9-2.fc9    development        22 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 22 M
Is this ok [y/N]: n 
Comment 3 Andrew Farris 2008-02-12 08:02:17 EST
Try doing that update without asking for system-config-firewall.  The situation is caused when both are 
trying to update, and only one gets skipped.  If you manually exclude either one, then skip-broken 
succeeds by skipping the other one.

If you try:
yum --skip-broken update
or yum --skip-broken update system-config-firewall*

I would expect it to reproduce the issue.
Comment 4 Seth Vidal 2008-03-12 12:48:43 EDT
Can you test 3.2.12 in rawhide?
Comment 5 Bill Nottingham 2008-03-12 13:01:51 EDT
The dependency issue isn't really there to test...
Comment 6 Seth Vidal 2008-03-14 11:17:01 EDT
okay. So, this is a tiny bit difficult to debug for the moment.

If you encounter it again, please open up a new bug.

Note You need to log in before you can comment on or make changes to this bug.