Bug 432180 - [DEPBLOAT] Requires openldap-server
[DEPBLOAT] Requires openldap-server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
8
All Linux
urgent Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 08:53 EST by Enrico Scholz
Modified: 2008-03-25 23:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 23:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2008-02-09 08:53:39 EST
Description of problem:

Please remove the openldap-server dependency as soon as possible. It is
absolutely not required for dhcp functionality and adds very heavy dependency bloat.


Version-Release number of selected component (if applicable):

dhcp-3.0.6-12.fc8
Comment 1 Enrico Scholz 2008-02-09 09:16:01 EST
Addition: current packaging seems to be due to the dhcp.schema file.   When
admin wants to use it, he would have to install openldap-servers on the dhcp
server and dhcp on all openldap-servers.  This is a very bad style.

Hence, the schema file should be put in a dhcp-openldap subpackage which
contains only this file and a 'Requires: openldap-server'
Comment 2 David Cantrell 2008-03-25 23:02:22 EDT
I'm not going to create a new package with the schema file in it.  I've removed the hard Requires: line for 
openldap-servers.  Fixed in dhcp-4.0.0-11.fc9 and later.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.