Bug 432182 - Override option does not work
Override option does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.6
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Jan Safranek
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 09:02 EST by John Willis
Modified: 2008-07-24 15:50 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0700
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:50:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Willis 2008-02-09 09:02:35 EST
Description of problem:

Inserting the snmpd.conf man page "override" example causes snmpd daemon to die.

Version-Release number of selected component (if applicable):

Tested in RHEL4u5 i386, x86_64 and RHEL4u6 i386, x86_64 using Red Hat provided 
net-snmp-5.1.2 as supplied on original Red Hat media for RHEL4u5 and RHEL4u6.

How reproducible:

Just follow the man page directions.

Steps to Reproduce:
1. read man page, man snmpd.conf
2. edit /etc/snmp/snmpd.conf
3. insert example [ override sysDescr.0 octet_str "my own sysDescr" ]
4. attempt to restart daemon

Result is the daemon dies and leaves a subsys lock file that has to be removed 
manually.

Actual results:

# vi /etc/snmp/snmpd.conf
# /etc/init.d/snmpd restart
Stopping snmpd: [ OK ]
Starting snmpd: [ OK ]
/etc/init.d/snmpd status
snmpd dead but subsys locked

# snmpwalk -v1 -c public localhost sysDescr.0
"hangs"
Timeout

Expected results:
# snmpwalk -v1 -c public localhost sysDescr.0
"my own sysDescr"

Additional info:

The upstream developers seem to have identified this as a problem long ago and 
backported a fix to 5.1.4 but not 5.1.2

I work with Enterprise client issues and the override option gets used a lot, 
not supporting RHEL4 is not an option for a least a year two.

Perhaps Red Hat could consider applying the 5.1.4 backport from upstream to a 
5.1.2 errata update? Or making a version of 5.1.4 known to have this option 
fixed available for RHEL4?

http://sourceforge.net/mailarchive/message.php?msg_id=02ca01c703e0%24cc2e4310%
24f20214ac%40bite.lt
http://sourceforge.net/mailarchive/message.php?msg_id=E1GCYFk-0007zG-97%40sc8-
sf-web2.sourceforge.net
http://sourceforge.net/mailarchive/message.php?msg_id=E1GCYFk-0007zG-97%40sc8-
sf-web2.sourceforge.net


Date: 2006-02-10 14:50
Sender: rstory
Logged In: YES 
user_id=76148

crash was fixed for 5.1.3 release line, however the token failed to
actually override. Fixed for 5.1.4. Should already be working in 5.2.x and
later releases.

http://net-snmp.svn.sourceforge.net/viewvc/net-snmp/branches/V5-1-patches/net-
snmp/agent/

  238 2006-02-15 15:25  rstory
  239 
  240    * agent/: snmp_agent.c, helpers/bulk_to_next.c
  241 , helpers/instance.c:
  242 
  243    - a tangled web of (temporary?) fixes for override
  244      - back out fix for 711465: override directive ignored with 
snmpbulkget
  245      - apply new fixes for 711465 (see bug report for gory details)
  246      - also fix override of table instance, reported on coders
Comment 1 John Willis 2008-02-09 09:06:41 EST
Actually any more recent version of net-snmp 5.2+ would be acceptable just as 
long as it was supported by Red Hat for RHEL4, perhaps the same version 
currently released with RHEL5 would be easiest or low maintenance since that is 
already being supported.
Comment 2 Jan Safranek 2008-02-11 09:41:34 EST
Sorry to disappoint you, but rebase to net-snmp-5.2 or supporting both
net-snmp-5.1 and any newer net-snmp version is not easily possible. If insist on
that, please contact you Red Hat Support at redhat.com/support.

Regarding the overrides, I have some problems to reproduce it. Override
statement does not crash the snmpd (this seems to be fixed since
net-snmp-5.1.2-11.EL4.7). On the other hand, the override does not work at all,
snmpd prints "Error: oid registration failed within the agent"
(net-snmp-5.1.2-11.el4.11).

Could you please update to latest net-snmp, retry your test and submit results
(together with exact net-snmp version)? In the meantime, I'll try to fix the bug
I observe and make override working again.
Comment 3 Jan Safranek 2008-02-11 09:48:18 EST
Note to self: svn diff -r 14240:14241 will make override working again.
The crash itself is fixed by net-snmp-5.1.2-override_bulk2.patch
Comment 4 John Willis 2008-02-12 02:04:18 EST
No disappointment, completely understand rebase probably wasn't in the cards.

Regarding the overrides.

I made a mistake and was testing on RHEL4U4 just before entering the bug.
It had net-snmp-5.1.2-11.EL4.7, and that was where I was getting seg fault.

I reinstalled RHEL4U4 made sure it was net-snmp-5.1.2-11.EL4.7 and re-tested.

It continues to seg fault when I put the example override statement in 
the /etc/snmp/snmpd.conf file.


Today I installed RHEL4U5i386 on my HVM and it has net-snmp-5.1.2-11.EL4.10 and 
does not seg fault, but also doesn't honor the "override" option.

# vi /etc/snmp/snmpd.conf
override sysDescr.0 octet_str "my own sysDescr"

# /etc/init.d/snmpd stop
# /etc/init.d/snmpd start

# snmpwalk -v1 -c public localhost sysDescr.0
SNMPv2-MIB::sysDescr.0 = STRING: Linux localhost.localdomain 2.6.9-55.EL #1 Fri 
Apr 20 16:35:59 EDT 2007 i686

You note to self looked interesting.. fixed today?.. or fixed by the Light of 
Other Days?

Thanks for your rapid response.
Comment 5 Jan Safranek 2008-02-12 04:29:44 EST
(In reply to comment #4)
> You note to self looked interesting.. fixed today?.. or fixed by the Light of 
> Other Days?

That's just private note so I do not forget about my investigations... I've just
forgot to tick the 'private' checkbox :)

I'll try to fix the override in RHEL 4.7 update.
Comment 6 RHEL Product and Program Management 2008-02-12 04:38:27 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 RHEL Product and Program Management 2008-02-12 04:39:57 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 Jan Safranek 2008-02-12 07:18:23 EST
lowering the severity - it does not crash anymore, it 'only' does not work :)
Comment 9 John Willis 2008-02-13 00:37:17 EST
an interesting play on words - "I had to chuckle a bit :-)" - the patient isn't 
bleeding, he's just dead, nothing critical here.. move along..

I found a temporary work around.

It's not pleasant, but the same functionality can be "emulated" using 
the "pass" option to hand the responsibility of the OID off to an outside shell 
script.

It's unpleasant for (1) security (2) loading (3) documentation reasons, not to 
mention the man pages don't document the current source seems to 
support "octet_str" data types although list of supported types doesn't include 
it.. what a fortunate accident ;-)

A fix in any of the releases current or past would be welcome.

Thanks
Comment 10 Jan Safranek 2008-02-13 03:26:52 EST
<joking>
(In reply to comment #9)
> an interesting play on words - "I had to chuckle a bit :-)" - the patient isn't 
> bleeding, he's just dead, nothing critical here.. move along..

Hey, the patient is in quite good shape, only missing one kidney - it's
definitely better than the patient dying every time when it uses the bad kidney.
The last surgeon stopped the bleeding, but forget to test it before sending the
patient home :). Anyway, the kidney should be working again in next update.

</joking>
Comment 12 John Willis 2008-02-14 05:54:16 EST
Sounds cool.

Please reassign this bug to the proper priority.

I never had so much fun loggin a bug in my life. 
Comment 16 errata-xmlrpc 2008-07-24 15:50:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0700.html

Note You need to log in before you can comment on or make changes to this bug.