Bug 432210 - selinux stops cups-pdf from working
selinux stops cups-pdf from working
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-09 17:51 EST by Andrew Wheeler
Modified: 2008-02-11 17:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 17:36:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from selinux troubleshooter browser (2.39 KB, text/plain)
2008-02-09 17:51 EST, Andrew Wheeler
no flags Details

  None (edit)
Description Andrew Wheeler 2008-02-09 17:51:41 EST
Description of problem:
selinux prevents cups-pdf from outputing to Out ${DESKTOP}

Version-Release number of selected component (if applicable):
selinux-policy-3.0.8-81.fc8 targeted
ghostscript-8.61-6.fc8
cups-pdf 2.4.6-6.fc8

How reproducible:
 

Steps to Reproduce:
1.yum install cups-pdf
2.open the printer press print test page 
3.
  
Actual results:
selinux denial

Expected results:
pdf page created on desktop or other folder as specified from
/etc/cups/cups-pdf.conf


Additional info:
Comment 1 Andrew Wheeler 2008-02-09 17:51:41 EST
Created attachment 294479 [details]
output from selinux troubleshooter browser
Comment 2 Daniel Walsh 2008-02-11 17:36:10 EST
This seems to be a customized behavior.  We do not want system apps to be able
to write to users homedirectories by default.

You can customize selinux policy to allow this by executing.

# grep cups /var/log/audit/audit.log | audit2allow -m mycups
# semodule -i mycups.pp


Note You need to log in before you can comment on or make changes to this bug.