Bug 432249 - View properties for directory crashes for invalid uid/gid
View properties for directory crashes for invalid uid/gid
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 08:00 EST by Paul Sorensen
Modified: 2015-03-03 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.20.0-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 06:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug buddy crash dump (949 bytes, application/octet-stream)
2008-02-28 23:22 EST, Paul Sorensen
no flags Details
fm_properties_owner_change_crash.patch (850 bytes, patch)
2008-03-07 11:29 EST, Tomáš Bžatek
no flags Details | Diff

  None (edit)
Description Paul Sorensen 2008-02-10 08:00:59 EST
Description of problem:
When attempting to view properties for a directory which has uid/gid which is
not assigned to a user or group, Nautilus will crash and restart.

Discovered this when I copied a .ssh directory from FC7 to F8. The uid and gid
for the user was not the same between the versions. Doing a dir showed 501 for
uid and gid rather than user ids.

Version-Release number of selected component (if applicable):
2.20.0

How reproducible:
Every time1

Steps to Reproduce:
1. mkdir qq
2. chown 999:999 qq
3. Try to view properties for qq

Assumes 999 was not previously assigned to a group or user.
  
Actual results:
Crash and restart

Expected results:
Properties dialog to be displayed

Additional info:
Comment 1 Tomáš Bžatek 2008-02-22 10:18:02 EST
Tested on clean Fedora 8 and confirming it's working for me.

nautilus-2.20.0-8.fc8
gnome-vfs2-2.20.1-1.fc8


Please confirm the directory is created on local filesystem (e.g. /tmp/...).
Also please provide versions of nautilus and gnome-vfs2 packages (use 'rpm -qa |
grep nautilus').
Comment 2 Paul Sorensen 2008-02-28 23:22:26 EST
Created attachment 296302 [details]
bug buddy crash dump
Comment 3 Paul Sorensen 2008-02-28 23:23:33 EST
I am running the most current updates:
nautilus-2.20.0-8.fc8
gnome-vfs2-2.20.1-1.fc8

Also saw problem with:
nautilus-2.20.0-6.fc8

I have F8 installed on 3 machines (i386, x86_64, x86_64) and all show the
problem. Although, I get slightly different results.

Further experimentation, narrowed the problem down.
1. Files are ok, problem only happens for directories.
2. Problem only happens when logged in as root.
3. As a test, installed from DVD distribution without updating.
Same problem occurred.

However, here I did get a bug buddy dialog and dump, which I attached. The error
is a NULL pointer to g_strsplit, now that makes it easier. Looking at the
nautilus-2.20.0 source from gnome.org, I see the problem in
src/file-manager/fm-properties-window.c The callback, changed_owner_callback()
calls combobox_get_active_entry() to get the "owner_text" which is passed to
g_strsplit() in the following line. Problem is, combobox_get_active_entry() will
return NULL if no owner is selected. Likely is the case for an unknown user
name. So, the g_strsplit() bombs because of the NULL pointer. 
Comment 4 Paul Sorensen 2008-02-29 07:56:03 EST
Problem also still persists in F9 alapha with the latest update:
nautilus-2.21.92-2.fc9.i386
Comment 5 Tomáš Bžatek 2008-03-07 11:29:35 EST
Created attachment 297205 [details]
fm_properties_owner_change_crash.patch

Thanks for the info, I didn't realized this is a root issue. Patch attached.
Comment 6 Fedora Update System 2008-03-10 06:37:13 EDT
nautilus-2.20.0-9.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-03-13 03:40:39 EDT
nautilus-2.20.0-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Paul Sorensen 2008-03-16 12:23:23 EDT
Tested with nautilus-2.20.0-9.fc8. Problem is solved and how properties works
correctly. So this bug probably could be closed. 

Note You need to log in before you can comment on or make changes to this bug.