Bug 432258 - Can't mount zip drive 100
Can't mount zip drive 100
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 10:00 EST by Stephen Miller
Modified: 2008-02-21 08:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 16:34:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (19.38 KB, text/plain)
2008-02-10 15:00 EST, Stephen Miller
no flags Details

  None (edit)
Description Stephen Miller 2008-02-10 10:00:54 EST
Description of problem:
error message from mount: 
mount: /dev/sda4 is not a valid block device
Version-Release number of selected component (if applicable): 
util-linux-ng-2.13-3.2.fc8.src.rpm (this is for "mount")
NOTE: 2 kernels on my computer: 2.6.23.14-107.fc8 and 2.6.23.14-115.fc8-i686

How reproducible:
100%

Steps to Reproduce:
1. MAKEDEV /dev/sda4
2. mount -t vfat /dev/sda4 mnt/zip100.0
3.
  
Actual results:
error message shown above

Expected results:
device should be mounted

Additional info: drive is powered, disk inserted, used to work with fc4.
Comment 1 Jon Stanley 2008-02-10 10:38:05 EST
Where are you getting /dev/sda4 from?  udev should be automatically creating
devices when a device is plugged in, there should be no need to manually make
any sort of devices.  Can you attach the output of 'dmesg' from your computer?
Comment 2 Stephen Miller 2008-02-10 15:00:04 EST
Created attachment 294508 [details]
dmesg
Comment 3 Stephen Miller 2008-02-13 09:07:36 EST
(In reply to comment #1)
> Where are you getting /dev/sda4 from?  udev should be automatically creating
> devices when a device is plugged in, there should be no need to manually make
> any sort of devices.  Can you attach the output of 'dmesg' from your computer?

Comment 4 Jon Stanley 2008-02-13 11:59:38 EST
I see no evidence here that a zip drive is actually attached.  Via what method
(USB, etc) is the drive attached?

There *is* a /dev/sda, but that's a 40GB hard drive.
Comment 5 Stephen Miller 2008-02-13 12:15:51 EST
It's a parallel device (zip 100.0), and always worked in FC4. Can't remember
whether or not I had to manually use MAKEDEV. If I manually edit fstab, I see
the device under "my computer", but can't mount it. Initially, it says "sda4
doesn't exist), implying that it knows sda4 is what's needed. If I then create
sda4 using MAKEDEV, it then says "sda4 is not a valid block device). Running
"file /dev/sda4", it says it's a block special (8/4). If I run "ls -al
/dev/sda4, I get 
brw-r----- 1 root disk 8, 4 2008-02-13 12:10 /dev/sda4.
Comment 6 Jon Stanley 2008-02-13 12:34:04 EST
One of the main differences between FC4 and F8 is the introduction of libata -
so that all ATA disks get abstracted as SCSI disks.  So there's some definite
collision if you were using /dev/sda4 before - that will no longer work.  I'm
honestly surprised to hear that a parallel zip drive still exists :). 
Unfortunately, the howto that Google dug up for me doesn't exist anymore, so I'm
not sure how to make this work.  I'll try and ping some developers.


Comment 7 Jon Stanley 2008-02-13 14:08:02 EST
Well searching through my gmail archive of fedora-list, I found something that
looks promising.  In one window, have a tail -f going of /var/log/messages.  In
another window, type 'modprobe ppa'.  There should be messages about finding the
zip drive with some luck.  I really wouldn't count on this long term, because
I've not been able to find anyone who has done anything with parport stuff for
about 5 years.  :)
Comment 8 Stephen Miller 2008-02-13 14:34:12 EST
Thanks, but no luck. I do notice in dmesg, however, this statement;ppa: Version
2.07 (for Linux 2.4.x). I'll just consider this device as being too old. It
still works on a windows computer, which is sufficient for my needs.
Thanks for your help.
Comment 9 Jon Stanley 2008-02-15 16:34:52 EST
I'll close this one CANTFIX then....
Comment 10 Chuck Ebbert 2008-02-20 17:03:56 EST
Zip drives can also be driven by the imm driver.
Comment 11 Stephen Miller 2008-02-21 08:34:17 EST
Tried using imm, no change. Thanks anyway.

Note You need to log in before you can comment on or make changes to this bug.