This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 432266 - rt2500pci throws ^@ to the console
rt2500pci throws ^@ to the console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-10 13:41 EST by Vaclav "sHINOBI" Misek
Modified: 2008-03-12 17:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 17:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -v (12.14 KB, application/octet-stream)
2008-02-10 13:42 EST, Vaclav "sHINOBI" Misek
no flags Details
lsmod (3.69 KB, application/octet-stream)
2008-02-10 13:43 EST, Vaclav "sHINOBI" Misek
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2008-02-10 13:41:27 EST
Description of problem:
When the wlan0 is started (doesn't matter if through NetworkManager or ifconfig
wlan0 up) it throws to the console ^@ characters approx. every second.

Version-Release number of selected component (if applicable):
kernel-2.6.23.14-115.fc8 (AFAIK all kernels in F 8)

How reproducible:
always

Steps to Reproduce:
1. start wlan0 interface
2.
3.
  
Actual results:


Expected results:
No characters to stdout as these blocks repeated key presses when key is held
down etc.

Additional info:
I upgraded to Alpha release and it behaves the same way.
Comment 1 Vaclav "sHINOBI" Misek 2008-02-10 13:42:11 EST
Created attachment 294502 [details]
lspci -v
Comment 2 Vaclav "sHINOBI" Misek 2008-02-10 13:43:05 EST
Created attachment 294503 [details]
lsmod
Comment 3 John W. Linville 2008-02-11 09:28:55 EST
Copying Ivo in case he has seen any similar wierdness...
Comment 4 Ivo van Doorn 2008-02-11 10:42:45 EST
Seems very much related to #43267, in fact it sounds more like that bug is a 
direct cause for the console bug.

But no I haven't seen this particular bug before (In opposite to #43267 which 
sounds all too familiar if this fedora kernel indeed contains rt2x00 2.1.0).
Comment 5 Vaclav "sHINOBI" Misek 2008-02-22 15:46:17 EST
Still persist in kernel 2.6.25-0.64.rc2.git5.fc9.
Comment 6 Ivo van Doorn 2008-02-25 17:40:15 EST
I have no real idea what can cause this, it sounds like memory corruption but
then you would also experience a crash.
It might have been caused by a kernel thread that hangs (fixed in rt2x00 2.1.3),
but I am not really convinced that could cause the above mentioned bug... :S
Comment 7 Vaclav "sHINOBI" Misek 2008-02-29 17:52:42 EST
Any idea how can I debug it or how to find more info?
Comment 8 John W. Linville 2008-03-04 14:09:02 EST
Vaclav, can you recreate the issue with the current rawhide kernels?  There 
have been a number of updates over the last month...
Comment 9 Vaclav "sHINOBI" Misek 2008-03-04 16:19:33 EST
Hi John, unfortunately the problem is still present in the latest rawhide kernel
2.6.25-0.87.rc3.git4.fc9
Comment 10 Vaclav "sHINOBI" Misek 2008-03-12 17:33:00 EDT
The latest koji kernel (with included rt2x00 2.1.4) 2.6.25-0.113.rc5.git2.fc9
did the trick and there are no such characters send to console. Thanks a lot Ivo.

Note You need to log in before you can comment on or make changes to this bug.