Bug 432279 - system-config-sound card doesn't know how to configure snd_hda_intel
Summary: system-config-sound card doesn't know how to configure snd_hda_intel
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-10 21:14 UTC by Hin-Tak Leung
Modified: 2008-02-21 09:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 14:02:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of first failure (143.54 KB, text/plain)
2008-02-10 21:14 UTC, Hin-Tak Leung
no flags Details
log of 2nd failure (48.74 KB, text/plain)
2008-02-10 21:15 UTC, Hin-Tak Leung
no flags Details
scsrun log (4.58 KB, text/plain)
2008-02-10 21:15 UTC, Hin-Tak Leung
no flags Details

Description Hin-Tak Leung 2008-02-10 21:14:26 UTC
Description of problem:

system-config-soundcord writes non-functional, and bogus info to /etc/modprobe.conf

Version-Release number of selected component (if applicable):

system-config-soundcard-2.0.6-11.fc8

How reproducible:

Twice, log to follow


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Once it write /etc/modprobe.conf

alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0

It also writes something like this:

options snd cards_limit=8
alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7


Expected results:

The working manual editing to /etc/modprobe.conf is:

alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel model=toshiba


Additional info:

System-config-soundcard also seems to have problem unloading the kernel module
and reloading (conflict with pulse audio?)

Comment 1 Hin-Tak Leung 2008-02-10 21:14:26 UTC
Created attachment 294510 [details]
log of first failure

Comment 2 Hin-Tak Leung 2008-02-10 21:15:21 UTC
Created attachment 294511 [details]
log of 2nd failure

Comment 3 Hin-Tak Leung 2008-02-10 21:15:59 UTC
Created attachment 294512 [details]
scsrun log

Comment 4 Martin Stransky 2008-02-20 14:02:05 UTC
> options snd-hda-intel model=toshiba

This specific configuration has to be fixed by upstream for all distros - file a
bug at www.alsa-project.org. We can keep a specific config for all models.

>  System-config-soundcard also seems to have problem unloading 
>  the kernel module and reloading (conflict with pulse audio?)

Yes, it's possible. s-c-s can't unload a kernel module when it's used by some
other app or the sound server.



Comment 5 Hin-Tak Leung 2008-02-20 23:18:30 UTC
fair enough - I just thought there are a few similiar bugs in redhat's bugzilla
and it would be more useful if redhat people file one bug on behalf of the 
bunch upstream.

I think the kernel module should try harder guessing what options to use
(e.g. default to model=auto), but there are still a few criticism
against sysmte-config-sound-card: 1) what it did insert, "model=0" is
none of any of the documented options, and letting the default (no kernel 
module parameters, or "model=auto")
taking over may work better in some cases (not in mine), (2) it was inserting
bogus entries on my 2nd attempt. (3) it could try to shut down the sound server,
or gives some hints on how to do so when it fails to unload the kernel module.

anyway, my current configuration works, and future version of the sound module
might just probe the hardware better, so this is probably not important... the
information about identifying hardware, etc in the logs may still be useful
if forwarded to the alsa people in a bundle together with some of the other bugs.

Comment 6 Martin Stransky 2008-02-21 09:18:33 UTC
(In reply to comment #5)
> fair enough - I just thought there are a few similiar bugs in redhat's bugzilla
> and it would be more useful if redhat people file one bug on behalf of the 
> bunch upstream.

I can't file the bug because i don't have your hardware available. There are
usually many hw-specific question when you file any hw specific bug.

> I think the kernel module should try harder guessing what options to use
> (e.g. default to model=auto), but there are still a few criticism
> against sysmte-config-sound-card: 1) what it did insert, "model=0" is
> none of any of the documented options, and letting the default (no kernel 
> module parameters, or "model=auto")
> taking over may work better in some cases (not in mine), (2) it was inserting
> bogus entries on my 2nd attempt. (3) it could try to shut down the sound server,
> or gives some hints on how to do so when it fails to unload the kernel module.

Yes, the current fedora sound setup is quite old and doesn't reflect the latest
changes. Unfortunately i don't have a time to work on it now. Feel free to
create any patch that improves it and i can review/merge it then.


Note You need to log in before you can comment on or make changes to this bug.