This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 432318 - No sounds during logout
No sounds during logout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 441522 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 04:13 EST by Marc
Modified: 2008-09-09 18:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc 2008-02-11 04:13:37 EST
Description of problem:

No sounds when the login window appears, even when sounds are set for the login
window, e.g., for when the login screen appears, login successful, login failed.
However, all other system sounds work when set-up.

Version-Release number of selected component (if applicable):

I think these sounds are controlled by pulseaudio-0.9.8-5.fc8.i386.rpm , but it
could be via the kernel, I'm not sure (kernel-2.6.23.14-115.fc8.i686.rpm).  

How reproducible:

Set-up system sounds, first as user, as previously set-up in FC6, Fedora 7, and
also for the login screen (login window).  System sounds work after re-boot, but
no sounds when login window appears.

Steps to Reproduce  (in all cases, system sounds set-up work fine):

1. Re-set the login window sounds and re-boot: no login window sound.
2. Tried again, and also set-up the same in root: no login window sound,
3. Re-installed Fedora 8 on hard disk in case it was an installation fault:
still no login window sounds.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joachim Frieben 2008-02-11 10:53:41 EST
Upgrading to gnome-session-2.21.90-2.fc9 finally brings back the login
sound. However, there is still no logout sound. As a matter of fact,
in my case [current "rawhide"], there are no other system sounds at all,
although it's possible to play each of them by clicking "Play" in "Sound
Preferences". Btw, this report appears to be a duplicate of "rawhide"
bug 421841.
Comment 2 Matthias Clasen 2008-03-03 00:06:41 EST
Event sounds during the session are back now. 
The logout sound seems to still be missing, I only heard part of it when I tried
just now.
Comment 3 Matthias Clasen 2008-04-08 13:15:40 EDT
*** Bug 441522 has been marked as a duplicate of this bug. ***
Comment 4 Joachim Frieben 2008-04-12 01:00:57 EDT
After downgrading from current "rawhide" where login/logout sounds are
actually working now [apart from a missing delay at logout cutting the
sound quite abruptly], login/logout sounds are still completely missing
from F8 [as of 2008-04-11 including updates and updates-testing]. Other
event sounds work correctly though.
Comment 5 Lennart Poettering 2008-09-09 18:47:24 EDT
In rawhide the logout sound will now be done by a script that uses libcanberra that will wait until the sound is fully played. The problem should hence be fixed. If it is not, fell free to reopen.

Note You need to log in before you can comment on or make changes to this bug.