Bug 432322 - Setup screen is huge with german locale
Setup screen is huge with german locale
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
: Regression
: 479924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 04:45 EST by Christian Jung
Modified: 2010-10-22 18:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed window properties (19.63 KB, application/octet-stream)
2008-02-11 04:45 EST, Christian Jung
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 515826 None None None Never

  None (edit)
Description Christian Jung 2008-02-11 04:45:28 EST
Description of problem:
If you start evolution for the first time, a setup wizard asks for account
settings. The window size is 1392 x 579 pixels.

Version-Release number of selected component (if applicable):
evolution-data-server-1.12.3-2.el5
evolution-2.12.3-1.el5
evolution-connector-2.12.3-2.el5
evolution-webcal-2.7.1-6
evolution-help-2.12.3-1.el5


How reproducible:
always

Steps to Reproduce:
1. Use evolution the first time, make sure the is no existing profile
2. LANG=de_DE evolution
3.
  
Actual results:
Setup wizard starts but uses huge window

Expected results:
Setup wizard start with max. windows size fitting into 1024x768 resolution.

Additional info:
Other locales seem to be affected too. But Window size is different. 
See attached xprop output for details
Comment 1 Christian Jung 2008-02-11 04:45:28 EST
Created attachment 294544 [details]
Detailed window properties
Comment 2 Matthew Barnes 2008-02-11 12:08:50 EST
Confirmed.  Also an issue in the upstream code base.  Looks like maybe the label
just needs to be word wrapped.
Comment 4 Milan Crha 2008-02-11 12:25:40 EST
OK, You can move it upstream.
Comment 5 Matthew Barnes 2008-02-11 12:57:09 EST
Opened an upstream bug for this:
http://bugzilla.gnome.org/show_bug.cgi?id=515826

This bug needs to stay open since it's for RHEL.
Comment 10 Matthew Barnes 2008-03-14 15:36:49 EDT
Upstream fixed this by modifiying the German translation.  I think we should be
able to do the same for RHEL 5.

Patch available.
Comment 13 RHEL Product and Program Management 2008-06-23 07:57:46 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 17 Matthew Barnes 2009-01-14 01:05:38 EST
*** Bug 479924 has been marked as a duplicate of this bug. ***
Comment 22 zhanghaiyan 2009-06-09 02:51:43 EDT
The bug can not be reproduced on RHEL5.4 with below packages:
evolution-2.12.3-18.el5
evolution-data-server-1.12.3-17.el5
evolution-connector-2.12.3-10.el5
Comment 24 errata-xmlrpc 2009-09-02 05:16:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1260.html

Note You need to log in before you can comment on or make changes to this bug.