Bug 432329 - python-nltk should use system python-yaml
python-nltk should use system python-yaml
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-nltk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
: Reopened
Depends On: 439711
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 05:14 EST by Denise Dumas
Modified: 2008-04-09 11:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.9-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 11:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2008-02-11 05:14:58 EST
Description of problem:

Not sure which package this should actually get assigned to, just posting
this to get an initial discussion going:

fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/__init__.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/composer.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/constructor.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/cyaml.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/cyaml.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/cyaml.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/cyaml.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/dumper.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/dumper.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/dumper.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/dumper.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/emitter.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/emitter.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/emitter.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/emitter.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/error.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/error.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/error.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/error.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/events.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/events.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/events.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/events.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/loader.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/loader.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/loader.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/loader.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/nodes.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/nodes.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/nodes.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/nodes.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.py in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/parser.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/reader.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/reader.pyc in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk_lite-0.9-0.1.b2.fc8.noarch.rpm
fileconflict for /usr/lib/python2.5/site-packages/yaml/reader.pyo in
PyYAML-3.05-2.fc9.noarch.rpm and python-nltk-0.9-0.2.b2.fc8.noarch.rpm


regards,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ignacio Vazquez-Abrams 2008-02-11 05:21:26 EST
Definitely a python-nltk issue.
Comment 2 Michel Alexandre Salim 2008-02-11 12:16:40 EST
Indeed. Thanks for reporting! Will fix this tonight.
Comment 3 Fedora Update System 2008-02-24 12:50:25 EST
python-nltk-0.9-2.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-02-24 12:51:11 EST
python-nltk-0.9-2.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-03-07 14:51:49 EST
python-nltk-0.9-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-03-07 14:52:49 EST
python-nltk-0.9-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Kirk Lowery 2008-03-11 09:34:43 EDT
During a yum update on an f8 system @ Tue Mar 11 09:31:53 EDT 2008, I received
the following error:

Error: Missing Dependency: PyYAML is needed by package python-nltk

Package PyYAML is not available from the standard Fedora 8 repos.

Kirk
Comment 8 Florian La Roche 2008-03-15 05:17:41 EDT
Seems this is still not fixed within the Fedora-devel tree.

regards,

Florian La Roche
Comment 9 Kirk Lowery 2008-03-15 10:20:24 EDT
The problem is the package PyYAML-3.05-2.fc8.rpm has supposedly been built but
it has not hit the update repo. See 

https://bugzilla.redhat.com/show_bug.cgi?id=426167

The builds for f7 and f8 are apparently still in testing, according to the bug.
It looks like yum updates to python-nltk will continue to be blocked until
PyYAML is released.
Comment 10 Michel Alexandre Salim 2008-03-30 17:37:16 EDT
fedora-devel has had python-nltk since Feb 23rd. I've filed a bug against PyYAML
asking the maintainer to push the updates to -stable. In the meantime, you can
install python-nltk with --enablerepo=updates-testing
Comment 12 Kirk Lowery 2008-03-31 09:12:14 EDT
Thanks for the follow through!

Kirk
Comment 13 Kirk Lowery 2008-04-01 08:46:29 EDT
One final note for the knowledgebase:

I upgraded to F8 from F7 and had the package
python-nltk_lite-0.9-0.1.b2.fc8.noarch installed. When I attempted to upgrade
with PyYAML as suggested above, I got conflicts with this package. I removed it,
and upgraded successfully.

I don't know what the differences are between these two packages, but they don't
co-exist nicely. From what I can see, python_nltk_lite is obsolete, hmmm?

Kirk
Comment 14 Michel Alexandre Salim 2008-04-02 21:17:19 EDT
Yes. Upstream obsoleted nltk-1.4.4 and shifted development to nltk_lite, and 
*then* decided to rename nltk_lite back to nltk. Which is why python_nltk 
obsoletes python-nltk_lite and has an epoch of 1 (so it is seen as newer than 
python-nltk-1.4.4 despite the lower version number).

Note You need to log in before you can comment on or make changes to this bug.