Bug 432347 - Aspell segfaults on empty file
Aspell segfaults on empty file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: aspell (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Schiffer
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 09:28 EST by Petr Muller
Modified: 2016-09-19 22:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, Aspell terminated unexpectedly with a segmentation fault if an empty file was checked for spelling. This bug was corrected in this update so that Aspell now works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 08:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Matthew Boyle 2008-04-28 15:50:13 EDT
looks like this has been fixed elsewhere: 

http://lists.opensuse.org/opensuse-commit/2007-08/msg01302.html

the patch to common/convert.cpp fixes the segfault for me (on FC8).

Comment 7 Petr Kovar 2011-10-07 08:17:51 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, Aspell terminated unexpectedly with a segmentation fault if an empty file was checked for spelling. This bug was corrected in this update so that Aspell now works as expected.
Comment 9 errata-xmlrpc 2011-10-17 08:59:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1372.html

Note You need to log in before you can comment on or make changes to this bug.