Bug 432349 - s-c-d crash
s-c-d crash
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-display (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-11 10:05 EST by Levente Farkas
Modified: 2012-04-18 10:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 10:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the wrong conf (617 bytes, application/octet-stream)
2008-04-02 07:30 EDT, Levente Farkas
no flags Details
the good conf (1.56 KB, application/octet-stream)
2008-04-02 07:30 EDT, Levente Farkas
no flags Details

  None (edit)
Description Levente Farkas 2008-02-11 10:05:19 EST
Description of problem:
on a fresh install i can't run s-c-d even with or without --reconfig:
---------------------------------------------------
[root@lfarkas-ghost ~]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 532, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 390, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range
[root@lfarkas-ghost ~]# system-config-display --reconfig
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 532, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.4/site-packages/rhpxl/xhwstate.py", line 390, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range
[root@lfarkas-ghost ~]# rpm -q system-config-display
system-config-display-1.0.48-2.el5
---------------------------------------------------

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
run:-)

Additional info:
Comment 1 Levente Farkas 2008-03-05 05:35:28 EST
any progress?
Comment 2 Matěj Cepl 2008-03-05 16:36:06 EST
What does happen when you move /etc/X11/xorg.conf away (rename or something like
that) and restart X? Does X work?

BTW, is your computer a real RHEL or CentOS or something like that?

And sorry for being slow on this bug -- we are now totally overloaded with
making Fedora Rawhide working.
Comment 3 Levente Farkas 2008-04-02 07:30:24 EDT
Created attachment 300048 [details]
the wrong conf
Comment 4 Levente Farkas 2008-04-02 07:30:56 EDT
Created attachment 300049 [details]
the good conf
Comment 5 Levente Farkas 2008-04-02 07:36:08 EDT
the strange that the above error no longer happened. but at the same time it's
generate wrong xorg.conf since the monitor section missing from it. even if the
--set-vsync= --set-hsync= given, what's more these option has no effect since
it's still not generate monitor section. what is the syntax of the --set-vsync=
--set-hsync= ?
and if you don't create monitor section X won't start in 1024x768 mode. eg run:
system-config-display --noui --reconfig --set-resolution=1024x768 --set-depth=24
--set-vsync=75 --set-hsync=81
will create the attached bad config. if i modify it to the attached good config
then it's working and X start in 1024x768.
so imho it's a bug.
anyway it i use the gui mode and choose a monitor then a good config generated,
but i need offline/non-interctive command line options.
Comment 6 Levente Farkas 2008-05-20 04:24:00 EDT
any progress with this bug?
Comment 7 Adam Jackson 2012-04-18 10:29:31 EDT
--set-hsync and --set-vsync should work as expected in 5.8 and later.

Note You need to log in before you can comment on or make changes to this bug.