Bug 432532 - gnutls fails to build with rawhide
gnutls fails to build with rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 12:29 EST by Kjartan Maraas
Modified: 2008-02-19 08:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 08:51:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2008-02-12 12:29:30 EST
Description of problem:

gcc -std=gnu99 -shared  .libs/libguile_gnutls_v_0_la-core.o
.libs/libguile_gnutls_v_0_la-errors.o .libs/libguile_gnutls_v_0_la-utils.o
-Wl,--whole-archive ../../lgl/.libs/liblgnu.a -Wl,--no-whole-archive 
-Wl,--rpath -Wl,/home/kmaraas/cvs/gnome/gnutls-2.0.4/lib/.libs -Wl,--rpath
-Wl,/opt/gnome2/lib -Wl,--rpath -Wl,/opt/gnome2/lib ../../lib/.libs/libgnutls.so
-L/opt/gnome2/lib /opt/gnome2/lib/libgcrypt.so -lnsl
/opt/gnome2/lib/libgpg-error.so -lguile  -march=core2 -pthread -march=core2
-pthread -Wl,-soname -Wl,libguile-gnutls-v-0.so.0 -o
.libs/libguile-gnutls-v-0.so.0.0.0
.libs/libguile_gnutls_v_0_la-errors.o: In function `scm_cell':
/usr/include/libguile/inline.h:69: multiple definition of `scm_cell'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:69: first
defined here
.libs/libguile_gnutls_v_0_la-errors.o: In function `scm_double_cell':
/usr/include/libguile/inline.h:146: multiple definition of `scm_double_cell'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:146: first
defined here
.libs/libguile_gnutls_v_0_la-errors.o: In function `scm_array_handle_ref':
/usr/include/libguile/inline.h:220: multiple definition of `scm_array_handle_ref'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:220: first
defined here
.libs/libguile_gnutls_v_0_la-errors.o: In function `scm_array_handle_set':
/usr/include/libguile/inline.h:235: multiple definition of `scm_array_handle_set'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:235: first
defined here
.libs/libguile_gnutls_v_0_la-errors.o: In function `scm_is_pair':
/usr/include/libguile/inline.h:250: multiple definition of `scm_is_pair'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:250: first
defined here
.libs/libguile_gnutls_v_0_la-utils.o: In function `scm_cell':
/usr/include/libguile/inline.h:69: multiple definition of `scm_cell'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:69: first
defined here
.libs/libguile_gnutls_v_0_la-utils.o: In function `scm_double_cell':
/usr/include/libguile/inline.h:146: multiple definition of `scm_double_cell'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:146: first
defined here
.libs/libguile_gnutls_v_0_la-utils.o: In function `scm_array_handle_ref':
/usr/include/libguile/inline.h:220: multiple definition of `scm_array_handle_ref'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:220: first
defined here
.libs/libguile_gnutls_v_0_la-utils.o: In function `scm_array_handle_set':
/usr/include/libguile/inline.h:235: multiple definition of `scm_array_handle_set'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:235: first
defined here
.libs/libguile_gnutls_v_0_la-utils.o: In function `scm_is_pair':
/usr/include/libguile/inline.h:250: multiple definition of `scm_is_pair'
.libs/libguile_gnutls_v_0_la-core.o:/usr/include/libguile/inline.h:250: first
defined here
collect2: ld returned 1 exit status
make[4]: *** [libguile-gnutls-v-0.la] Error 1
make[4]: Leaving directory `/home/kmaraas/cvs/gnome/gnutls-2.0.4/guile/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/kmaraas/cvs/gnome/gnutls-2.0.4/guile/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/kmaraas/cvs/gnome/gnutls-2.0.4/guile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kmaraas/cvs/gnome/gnutls-2.0.4'
make: *** [all] Error 2
*** error during stage build of gnutls: ########## Error running make   *** [17/151]

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2008-02-19 08:51:20 EST
I cannot reproduce it with a mock rebuild with the current rawhide.

Note You need to log in before you can comment on or make changes to this bug.