Bug 432538 - Selecting 'Ask on logout' in gnome-session-properties doesn't prompt user to save session on logout.
Selecting 'Ask on logout' in gnome-session-properties doesn't prompt user to ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-session (Show other bugs)
5.1
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks: 499522
  Show dependency treegraph
 
Reported: 2008-02-12 12:46 EST by Michael J. Carter
Modified: 2013-04-12 15:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnome-session-2.16.0-8.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 06:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 347979 None None None Never

  None (edit)
Description Michael J. Carter 2008-02-12 12:46:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070820 BonEcho/2.0.0.6

Description of problem:


Version-Release number of selected component (if applicable):
gnome-session-2.16.0-6.el5

How reproducible:
Always


Steps to Reproduce:
1. System->Preferences->More Preferences->Sessions
2. Select 'Session Options' tab.
3. Select 'Ask on logout'
4. System->Logout

Actual Results:
Logout confirmation dialog pops up.

Expected Results:
Logout confirmation dialog with option to save session should pop up.

Additional info:
Comment 1 Ray Strode [halfline] 2008-12-12 11:46:53 EST
What happened here is that we moved the logout dialog from gnome-session to gnome-panel.  gnome-panel doesn't look at the setting anymore.

The UI element should probably be removed, since it doesn't do anything, and potentially get replaced with a "Save session now" button in the dialog.
Comment 2 RHEL Product and Program Management 2009-03-26 12:53:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 14 errata-xmlrpc 2010-09-22 06:08:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0709.html

Note You need to log in before you can comment on or make changes to this bug.