Bug 432595 - Missing Dependencys for xine-lib-extras-nonfree and beagle
Missing Dependencys for xine-lib-extras-nonfree and beagle
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 02:10 EST by Thomas Schweikle
Modified: 2008-03-23 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-23 11:42:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2008-02-13 02:10:41 EST
Description of problem:
Missing dependencies
 xine-lib = 1.1.10.1 is needed by package xine-lib-extras-nonfree
 libwv-1.2.so.3 is needed by package beagle

Both are not found in the repository description file.

Version-Release number of selected component (if applicable):
 beagle-gui.i386 0:0.2.18-4.fc8
 beagle.i386 0:0.2.18-4.fc8
 xine-lib-extras-nonfree.i386 0:1.1.10.1-1.lvn8

How reproducible:
 always if one of these packages: xine-lib-extras-nonfree
 or beagle, is installed.

Steps to Reproduce:
1. Have Fedora installed from CD/DVD
2. Upgrade using "yum -y update"
3.
  
Actual results:
[...]
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package beagle-gui.i386 0:0.2.18-4.fc8 set to be updated
---> Package beagle.i386 0:0.2.18-4.fc8 set to be updated
--> Processing Dependency: libwv-1.2.so.3 for package: beagle
---> Package xine-lib-extras-nonfree.i386 0:1.1.10.1-1.lvn8 set to be updated
--> Processing Dependency: xine-lib = 1.1.10.1 for package: xine-lib-extras-
nonfree
--> Finished Dependency Resolution
Error: Missing Dependency: xine-lib = 1.1.10.1 is needed by package xine-lib-
extras-nonfree
Error: Missing Dependency: libwv-1.2.so.3 is needed by package beagle


Expected results:
Installing/Upgrading dependencies, installing/upgrading packages

Additional info:
This is for more than three weeks now, I assume all mirrors up to date!
Comment 1 Adel Gadllah 2008-02-13 02:40:42 EST
The xine update got pushed yesterday and is on the master mirror so this one is
a mirror not in sync problem. 
As for libwv its odd. 
Can you try
"yum clean all" before doing the update?
does yum install wv before updating work?
Comment 2 Thomas Schweikle 2008-02-13 03:09:01 EST
It is not on "mirrors.kernel.org" and it is not on "ftp.stud.th-esslingen.de" 
at the moment (Mi, 13. Feb. 2008, 8:56 CET).

With libwv:
there is no package providing libwv-1.2.so.3 within the repository.
Comment 3 Adel Gadllah 2008-02-13 03:18:26 EST
The package is wv (which provides libwv-1.2.so.3) not libwv and its on the
mirrors see:
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/Packages/wv-1.2.4-2.fc8.i386.rpm
Comment 4 Thomas Schweikle 2008-02-13 03:28:53 EST
The package is not found by yum (Aaaaaarrrrggggghhhhh!!!!! ---- please fix 
this!)

it is located in "http://mirror/.../fedora/releases/8/Everything/i386/os/
Packages/wv-1.2.4-2.fc8.i386.rpm" and can be installed using
"rpm -vhi http://mirror/.../fedora/releases/8/Everything/i386/os/Packages/
wv-1.2.4-2.fc8.i386.rpm"

After installing manualy I was able to upgrade at least beagle and beagle-gui 
with:
"yum -y --skip-broken update"

xine-lib is only available with version 1.1.9.1-3.fc8 on all mirrors I have 
checked. Maybe in a few hours ...
Comment 5 Adel Gadllah 2008-02-13 06:53:03 EST
(In reply to comment #4)
> The package is not found by yum (Aaaaaarrrrggggghhhhh!!!!! ---- please fix 
> this!)

Works here... 
Can you attach the files in /etc/yum.repos.d/ ? (fedora.repo and
fedora-updates.repo)
Comment 6 Thomas Schweikle 2008-03-10 18:12:54 EDT
Same Problem as in "Bug 428946". repodata-files not correctly build on the 
server side. They are missing some of the files within the repository, in tune 
yum looks at them as unresolvable dependencies, even if they are resolvable.

This is more a server side problem. Maybe there is an other bug report related 
to it and we could mark this one as dupplicate of it?
Comment 7 Adel Gadllah 2008-03-23 11:42:24 EDT
Well this is not a bug in beagle, if its a bug it all. Its a mirror/repo issue.

Note You need to log in before you can comment on or make changes to this bug.