Bug 432625 - [RFE:] Please consider upgrade to KDE4 version
[RFE:] Please consider upgrade to KDE4 version
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rsibreak (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 08:53 EST by Sebastian Vahl
Modified: 2010-02-24 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-24 18:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch against current spec for KDE4 version (4.32 KB, text/x-diff)
2008-02-13 08:53 EST, Sebastian Vahl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 157781 None None None Never

  None (edit)
Description Sebastian Vahl 2008-02-13 08:53:30 EST
There is existing a KDE4 version of rsibreak as a beta version. In a short 
test the normal functionality is like the KDE3 version. Only the new provided 
plasma applet seems to be a placebo (It's not doing anything here). 

I'll attach a patch for the spec which is working for i386 and x86_64. Only 
ppc and ppc64 aren't compiling atm: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=422844
This is already filed as a bug upstream: 
https://bugs.kde.org/show_bug.cgi?id=157781

If this is fixed the package should be good enough.
Comment 1 Sebastian Vahl 2008-02-13 08:53:30 EST
Created attachment 294785 [details]
Patch against current spec for KDE4 version
Comment 2 Roland Wolters 2008-02-13 19:47:20 EST
I'll keep an eye on the KDE-bug, when it's fixed I will try to upgrade the 
package. Thx for the patch so far.
Comment 3 Rex Dieter 2008-02-14 09:10:20 EST
CMakeLists.txt contains:
add_definitions (-mmmx)
wtf?  easy enought to patch out.
Comment 4 Rex Dieter 2008-02-14 09:33:47 EST
scratch build including the patch I submitted upstream:
http://koji.fedoraproject.org/koji/taskinfo?taskID=426609
Comment 5 Sebastian Vahl 2008-02-14 09:41:22 EST
Build failed:
/usr/lib/gcc/i386-redhat-linux/4.3.0/include/mmintrin.h:35:3: error: #error "MMX
instruction set not enabled"

Also the upstream maintainer suggests to not build for ppc and ppc64 right now:
http://bugs.kde.org/show_bug.cgi?id=157781#c3

So, until this is really fixed, we should stay with rsibreak-0.8.0. 
Comment 6 Rex Dieter 2008-02-14 09:43:47 EST
I can't imagine how/why mmx is required for this, but yeah, currently not
desirable as-is.
Comment 7 Jon Stanley 2008-04-23 16:30:35 EDT
Adding FutureFeature keyword to RFE's.
Comment 8 Roland Wolters 2010-02-24 18:24:05 EST
Closed, we ship rsibreak 0.10.0 these days.

Note You need to log in before you can comment on or make changes to this bug.