Bug 432635 - UnboundLocalError: local variable 'desc' referenced before assignment
UnboundLocalError: local variable 'desc' referenced before assignment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity high
: beta
: ---
Assigned To: David Cantrell
Milan Zazrivec
: Regression
: 432678 (view as bug list)
Depends On:
Blocks: 456097
  Show dependency treegraph
 
Reported: 2008-02-13 09:38 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (67.76 KB, text/plain)
2008-02-13 09:38 EST, James Laska
no flags Details
network_text.patch (507 bytes, patch)
2008-02-13 09:50 EST, James Laska
no flags Details | Diff

  None (edit)
Description James Laska 2008-02-13 09:38:01 EST
Description of problem:

During a manual text-mode install of RHEL5.2-Server-20080212.0/ppc
(anaconda-11.1.2.100-1) I hit the following traceback when entering step 'network'.

Traceback (most recent call first):                                             
  File "/usr/lib/anaconda/textw/network_text.py", line 596, in __call__
    self.devListDescs[devname] = desc
  File "/usr/lib/anaconda/text.py", line 565, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 982, in ?
    anaconda.intf.run(anaconda)
UnboundLocalError: local variable 'desc' referenced before assignment


Version-Release number of selected component (if applicable):


How reproducible:
100% during text-mode manual install


Steps to Reproduce:
1. Boot installer into text mode
2. Proceed to network screen
  
Actual results:
 - see anacdump.txt

Expected results:
 - no traceback

Additional info:
 - does not appear to affect kickstart installations
 - does not appear to affect graphical installations
Comment 1 James Laska 2008-02-13 09:38:01 EST
Created attachment 294793 [details]
anacdump.txt
Comment 2 James Laska 2008-02-13 09:50:56 EST
Created attachment 294794 [details]
network_text.patch

Using the attached patch works around the issue ... but may not be properly
initializing the variable as intended.

Tested with updates.img
Comment 4 Chris Lumens 2008-02-13 14:52:59 EST
*** Bug 432678 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2008-02-13 16:34:19 EST
Fix in anaconda-11.1.2.101-1
Comment 8 Milan Zazrivec 2008-02-18 07:25:40 EST
Verified with RHEL5.2-Server-20080217.nightly / anaconda-11.1.2.101-1.
Comment 10 errata-xmlrpc 2008-05-21 11:33:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html

Note You need to log in before you can comment on or make changes to this bug.