Bug 432641 - .treeinfo/.discinfo not documented
.treeinfo/.discinfo not documented
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 10:36 EST by Alexander Todorov
Modified: 2008-04-07 10:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 10:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-02-13 10:36:20 EST
Description of problem:
Internal format of .treeinfo/.discinfo files is not documented.

How reproducible:
100%

Additional info:
Although contents are somewhat self explanatory the format of these files is not
documented anywhere. It's important since they are part of the release
engineering process and lack of documentation prevents other projects to easily
develop their code. These are all projects that for some reason will need access
to the tree structure or just some information.
Comment 1 Joel Andres Granados 2008-02-14 10:58:22 EST
Impact on the actual anaconda workings is low.
Comment 2 Joel Andres Granados 2008-04-07 10:02:35 EDT
for the .treeinfo file we follow rfc 822 (standard ini file format)
We don't follow any specific format for the .discinfo file.  we basically put
every element of information on one line.  Dont think thats documentable.

Note You need to log in before you can comment on or make changes to this bug.