Bug 432720 - cannot load kickstart file via nfs
Summary: cannot load kickstart file via nfs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 433358 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-13 23:50 UTC by Orion Poplawski
Modified: 2008-03-17 18:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 18:14:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2008-02-13 23:50:41 UTC
Description of problem:

PXE boot config:

        kernel fedora/development/i386/vmlinuz
        append root=/dev/ram initrd=fedora/development/i386/initrd.img
ks=nfs:saga:/export/data1/ks/rawhide-laptop.cfg nokill

VT3:

INFO : doing kickstart... setting it up
INFO : url is saga:/export/data1/ks/rawhide-laptop.cfg
INFO : file location nfs://saga:/export/data1/ks/rawhide-laptop.cfg
ERROR : failed to mount nfs source

I don't see any mount attempts from the system in the server's logs.

Version-Release number of selected component (if applicable):
11.4.0.4-2

Comment 1 Chris Lumens 2008-02-14 14:45:10 UTC
I don't think /bin/mount was getting included in the images, which would be
what's responsible here.  This should be fixed in the next build of anaconda.

Comment 2 Chris Lumens 2008-02-19 15:02:56 UTC
*** Bug 433358 has been marked as a duplicate of this bug. ***

Comment 3 Orion Poplawski 2008-02-19 16:09:08 UTC
Still no go with 11.4.0.36

Comment 4 Orion Poplawski 2008-02-19 16:10:21 UTC
At least this time I see a mount request in the server logs.

Comment 5 Orion Poplawski 2008-02-27 18:59:19 UTC
Works with today's rawhide.

Comment 6 Orion Poplawski 2008-03-17 18:05:43 UTC
This is back again with 10.4.0.53.  Same error as before, no mount request in
server logs.

Comment 7 Chris Lumens 2008-03-17 18:14:55 UTC
Peter fixed this earlier today.  It'll be in the next build.


Note You need to log in before you can comment on or make changes to this bug.