Bug 432733 - uses the wrong optimization flags on ppc
uses the wrong optimization flags on ppc
Product: Fedora
Classification: Fedora
Component: sonic-visualiser (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-02-13 21:22 EST by Michel Alexandre Salim
Modified: 2008-02-24 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-24 20:14:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-02-13 21:22:40 EST
Description of problem:
sonic-visualiser (in the Fedora packages CVS) uses qmake-qt4 to generate its
Makefile; the generated file is good for building on all platforms (including
ppc64) with the exception of ppc.

On ppc, for some reason the optimization flags for x86 is used

Version-Release number of selected component (if applicable):
The latest version as used by koji/mock

How reproducible:

Steps to Reproduce:
1. checkout sonic-visualiser
2. make build

Actual results:
The ppc builder will fail

Expected results:
Should not fail: see URL included for the build result if ppc is ExcludeArch-ed.

Additional info:
Comment 1 Rex Dieter 2008-02-13 22:57:17 EST
A scratch build including the failed ppc arch would be much more helpful.
Comment 2 Rex Dieter 2008-02-14 08:06:06 EST
Tried a scratch build, it would appear rawhide has broken deps atm:
DEBUG util.py:261:  Error: Missing Dependency: xpeex-devel is needed by package
Comment 3 Rex Dieter 2008-02-14 08:24:59 EST
OK, tried again, building for dist-f8:
Comment 4 Rex Dieter 2008-02-14 08:26:06 EST
No clue where these are coming from:
cc1plus: error: unrecognized command line option "-march=pentium3"
cc1plus: error: unrecognized command line option "-mfpmath=sse"

definitely aren't our default $RPM_OPT_FLAGS
Comment 5 Rex Dieter 2008-02-14 08:28:55 EST
sonic-visualiser's bug, not ours:
-march=pentium3 -mfpmath=sse

omit/patch-out those arch-specific compiler optimizations, and you'll be better off.
Comment 6 Michel Alexandre Salim 2008-02-14 23:02:38 EST
Aha! Thanks.
Comment 7 Michel Alexandre Salim 2008-02-24 20:14:18 EST
Fixed in Rawhide; stable builds awaiting libfishsound fix entering the updates tree

Note You need to log in before you can comment on or make changes to this bug.