Bug 432778 - [PATCH] Fix build with gcc-4.3
Summary: [PATCH] Fix build with gcc-4.3
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rb_libtorrent   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-14 11:17 UTC by Adel Gadllah
Modified: 2008-02-15 07:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 07:18:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix gcc-4.3 build (1.82 KB, patch)
2008-02-14 11:17 UTC, Adel Gadllah
no flags Details | Diff

Description Adel Gadllah 2008-02-14 11:17:10 UTC
Description of problem:

I have created a patch that fixes libtorrent to build with gcc-4.3. Its quite
simply (only adding some missing includes). 
The patch does not only fix rb_libtorrent but all apps that depend on it. 
Since the automated mass rebuild will be starten on Feb 18 it would be nice to
get the patch commited before to avoid failed builds.

If you don't mind I can go ahead and commit the patch.

Patch is attached.

Comment 1 Adel Gadllah 2008-02-14 11:17:10 UTC
Created attachment 294907 [details]
Fix gcc-4.3 build

Comment 2 Peter Gordon 2008-02-15 07:18:14 UTC
Thanks very much. 

I've forward-ported it to 0.12.1 and committed it to CVS. 0.12.1-1 should hit
the next Rawhide push with this fix included.


Note You need to log in before you can comment on or make changes to this bug.