Bug 432788 - Major release upgrade: ls: /boot/initrd*kdump.img: No such file or directory
Major release upgrade: ls: /boot/initrd*kdump.img: No such file or directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
:
: 437451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 07:05 EST by Milan Zazrivec
Modified: 2008-05-21 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0313
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-02-14 07:05:14 EST
Description of problem:
Anaconda upgrade RHEL4.6::AS -> RHEL5.2-Server-20080212.0 (ppc)
produces following upgrade error when upgrading firstboot:

...
Upgrading firstboot - 1.4.27.3-1.el5.noarch
warning: /usr/X11R6/lib/X11/fonts/misc/fonts.alias saved as
/usr/X11R6/lib/X11/fonts/misc/fonts.alias.rpmsave
ls: /boot/initrd*kdump.img: No such file or directory
warning: /etc/sysconfig/rhn/up2date-uuid saved as
/etc/sysconfig/rhn/up2date-uuid.rpmsave
warning: /etc/sysconfig/rhn/rhn-applet saved as
/etc/sysconfig/rhn/rhn-applet.rpmsave
warning: /etc/hotplug/usb.usermap saved as /etc/hotplug/usb.usermap.rpmsave
warning: /etc/selinux/targeted/policy/policy.18 saved as
/etc/selinux/targeted/policy/policy.18.rpmsave
warning: /etc/selinux/targeted/booleans saved as
/etc/selinux/targeted/booleans.rpmsave
Could not parse file '/usr/share/applications/redhat-gnomemeeting.desktop':
Failed to open file '/usr/share/applications/redhat-gnomemeeting.desktop': No
such file or directory
Could not parse file '/usr/share/applications/redhat-evolution.desktop': Failed
to open file '/usr/share/applications/redhat-evolution.desktop': No such file or
directory
Could not parse file '/usr/share/applications/redhat-gnomemeeting.desktop':
Failed to open file '/usr/share/applications/redhat-gnomemeeting.desktop': No
such file or directory
Could not parse file '/usr/share/applications/redhat-evolution.desktop': Failed
to open file '/usr/share/applications/redhat-evolution.desktop': No such file or
directory
warning: /etc/iiim/le.xml.conf saved as /etc/iiim/le.xml.conf.rpmsave
...

Version-Release number of selected component (if applicable):
firstboot-1.4.27.3-1.el5

How reproducible:
Always
Comment 2 RHEL Product and Program Management 2008-02-15 10:27:05 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Chris Lumens 2008-02-15 10:40:17 EST
I don't see what could be causing this.  As you can see below, not much is
happening in the scriptlets for either the old version of the package or the new
version.  firstboot itself doesn't care about any of the files listed above.

$ rpm -qp --scripts firstboot-1.3.39-6.noarch.rpm 
warning: firstboot-1.3.39-6.noarch.rpm: Header V3 DSA signature: NOKEY, key ID
db42a60e
postinstall scriptlet (using /bin/sh):
if ! [ -f /etc/sysconfig/firstboot ]
then
  chkconfig --add firstboot
fi
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
  rm -rf /usr/share/firstboot/*.pyc
  rm -rf /usr/share/firstboot/modules/*.pyc
  chkconfig --del firstboot
fi


$ rpm -qp --scripts firstboot-1.4.27.3-1.el5.noarch.rpm 
warning: firstboot-1.4.27.3-1.el5.noarch.rpm: Header V3 DSA signature: NOKEY,
key ID 37017186
preuninstall scriptlet (using /bin/sh):
if [ $1 = 0 ]; then
  rm -rf /usr/share/firstboot/*.pyc
  rm -rf /usr/share/firstboot/modules/*.pyc
fi
Comment 5 Denise Dumas 2008-03-11 10:19:03 EDT
setting this as an exception so Brock has time to verify ..
Comment 6 Jarod Wilson 2008-03-15 20:57:22 EDT
This has gotta be some sort of %trigger-driven thing, probably in kexec-tools. I
just hit the same error message rpm -e'ing a kernel:

# rpm -e kernel-2.6.18-84.el5
ls: /boot/initrd*kdump.img: No such file or directory

Okay, yeah, its kexec-tools, here's the guilty snippet from said package's spec:

%triggerpostun -- kernel
# List out the initrds here, strip out version nubmers
# and search for corresponding kernel installs, if a kernel
# is not found, remove the corresponding kdump initrd

#start by getting a list of all the kdump initrds
for i in `ls /boot/initrd*kdump.img`
do
        KDVER=`echo $i | sed -e's/^.*initrd-//' -e's/kdump.*$//'`
        if [ ! -e /boot/vmlinuz-$KDVER ]
        then
                # We have found an initrd with no corresponding kernel
                # so we should be able to remove it
                rm -f $i
        fi
done

This is busted on two levels though... 1st, that it doesn't suppress output if
there's nothing there (this bug). 2nd, it won't ever work on ia64, since the
kdump initrds are in /boot/efi/efi/redhat/.

Changing component to kexec-tools for Neil to fix up...
Comment 10 CAI Qian 2008-03-26 04:39:26 EDT
*** Bug 437451 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2008-05-21 11:23:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0313.html

Note You need to log in before you can comment on or make changes to this bug.