Bug 432796 - Package xorg-x11-server-Xorg conflicts with kernel < 2.6.18-60.el5.
Package xorg-x11-server-Xorg conflicts with kernel < 2.6.18-60.el5.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.2
ia64 Linux
low Severity low
: beta
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 08:19 EST by Alexander Todorov
Modified: 2008-05-21 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0446
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-02-14 08:19:49 EST
Description of problem:
Error during upgrade from RHEL5-Server/U1-> RHEL5.2 with the following error:
Package xorg-x11-server-Xorg conflicts with kernel < 2.6.18-60.el5.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.1.1-48.36.el5.ia64.rpm
RHEL5.2-Server-20080212.0
kernel-2.6.18-79.el5.ia64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL-5-Server/U1
2. Upgrade to RHEL5.2-Server-20080212.0 with yum

  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2008-02-14 08:26:57 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Adam Jackson 2008-02-14 10:45:53 EST
The Conflicts: is intentional:

### RHEL-specific notes
# ia64: mmap-{expansion,failure} patches require kernel support (#233981)
%ifarch ia64
Conflicts: kernel < 2.6.18-60.el5
%endif

So presumably however you're upgrading isn't removing all the old kernels.

Alternatively we could just take that conflict out and dump a noisy message in
the X log when we try to run against a too-old kernel.

Either way, devel ack.
Comment 7 James Laska 2008-02-20 15:13:00 EST
Eeew.  This customer case here is they install U1 (or GOLD) and yum upgrade to
the latest content on RHN.

This issue seems to suggest that the procedure for RHEL-5/U2/ia64 should change to:
 1) yum update kernel
 2) reboot into new kernel
 3) yum remove old kernel
 4) yum update

I think that's too much of a departure from the expectation.  

Ajax, would it be sufficient to have xorg-x11-server-Xorg

Require: kernel >= 2.6.18-60.el5

Comment 9 Kevin E. Martin 2008-02-20 17:29:25 EST
(In reply to comment #7)
> Ajax, would it be sufficient to have xorg-x11-server-Xorg
> 
> Require: kernel >= 2.6.18-60.el5

This has the problem that if they boot with an older kernel, then 233981 is
back, so we will also have to make the X server change ajax suggested in comment #4:

> Alternatively we could just take that conflict out and dump a noisy message in
> the X log when we try to run against a too-old kernel.

I will ask ajax to do that when he gets in tomorrow morning.
Comment 11 Dave Airlie 2008-02-20 18:08:09 EST
I'll make the X server produce the following warning.

"WARNING: You are running an kernel older than 2.6.18-60.el5. This is
incompatible with the X server you are running.
Please boot a kernel later than 2.6.18-60-el5 to avoid bug 233981, where the X
server causes an MCA on certain IA64 hardware."

The X server won't crash it will just print this out to the log.

I'll also remove the requires.
Comment 12 Alexander Todorov 2008-02-21 04:03:53 EST
Does it make sense to release note the above warning? 
Comment 13 Jonathan Blandford 2008-02-21 09:44:23 EST
It looks looks like the package is built in xorg-x11-server-1.1.1-48.38.el5. 
Moving to modified.
Comment 18 errata-xmlrpc 2008-05-21 12:56:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0446.html

Note You need to log in before you can comment on or make changes to this bug.