Bug 432827 - SELinux is preventing /usr/sbin/gdm-binary (unconfined_t) "transition" to /etc/X11/xinit/Xsession (unconfined_t).
Summary: SELinux is preventing /usr/sbin/gdm-binary (unconfined_t) "transition" to /et...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-14 16:55 UTC by Scott Washburn
Modified: 2008-02-26 21:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 21:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Washburn 2008-02-14 16:55:25 UTC
Description of problem:
Sigining on as root causes this problem.  Turning off SELinux is only way to fix it.

avc: denied { transition } for comm="gdm-binary" dev=dm-0 egid=0 euid=0
exe="/usr/sbin/gdm-binary" exit=-13 fsgid=0 fsuid=0 gid=0 items=0
path="/etc/X11/xinit/Xsession" pid=3888
scontext=system_u:system_r:unconfined_t:s0 sgid=0
subj=system_u:system_r:unconfined_t:s0 suid=0 tclass=process
tcontext=root:system_r:unconfined_t:s0-s0:c0.c1023 tty=(none) uid=0 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Scott Washburn 2008-02-14 17:39:07 UTC
Target Context:  root:system_r:unconfined_t:SystemLow-SystemHighTarget
Objects:  /etc/X11/xinit/Xsession [ process ]Affected RPM
Packages:  xorg-x11-xinit-1.0.2-13.el5 [target]Policy
RPM:  selinux-policy-2.4.6-106.el5_1.3Selinux Enabled:  TruePolicy Type:  targeted

Comment 2 Daniel Walsh 2008-02-14 20:14:29 UTC
THis looks like gdm is running as unconfined_t rather then gdm?

Did you tun gdm in a debugger?




Note You need to log in before you can comment on or make changes to this bug.