This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 432880 - the command instmodsh for the newest perl install is not working
the command instmodsh for the newest perl install is not working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: perl (Show other bugs)
4.8
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 17:00 EST by Sia Najafi
Modified: 2009-05-18 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sia Najafi 2008-02-14 17:00:46 EST
Description of problem:running the command /usr/bin/instmodsh produces the error
syntax error at /usr/bin/instmodsh line 73, near "else"
Global symbol "$file" requires explicit package name at /usr/bin/instmodsh line 
73.
syntax error at /usr/bin/instmodsh line 96, near "}"
Execution of /usr/bin/instmodsh aborted due to compilation errors.
Version-Release number of selected component (if applicable): it is perl 
component rpm -qf /usr/bin/instmodsh  
perl-5.8.5-36.el4_5.2


How reproducible: the command is reproducible everytime


Steps to Reproduce:
1./usr/bin/instmodsh
2.
3.
  
Actual results:
syntax error at /usr/bin/instmodsh line 73, near "else"
Global symbol "$file" requires explicit package name at /usr/bin/instmodsh line 
73.
syntax error at /usr/bin/instmodsh line 96, near "}"
Execution of /usr/bin/instmodsh aborted due to compilation errors.


Expected results:
Available commands are:
   l            - List all installed modules
   m <module>   - Select a module
   q            - Quit the program


Additional info:
Comment 2 RHEL Product and Program Management 2008-09-05 13:15:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2009-05-18 16:08:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0961.html

Note You need to log in before you can comment on or make changes to this bug.