Bug 432942 - runlevel 1 on/off not handled by chkconfig
Summary: runlevel 1 on/off not handled by chkconfig
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: chkconfig   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-15 10:37 UTC by Berthold Cogel
Modified: 2018-11-28 19:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 15:45:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Berthold Cogel 2008-02-15 10:37:48 UTC
Description of problem:
chkconfig doesn't seem to handle runlevel 1 properly

[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Ein   2:Ein   3:Ein   4:Ein   5:Ein   6:Aus
[root@nagios-rzkb ~]# chkconfig cpuspeed off
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Ein   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus
[root@nagios-rzkb ~]# chkconfig cpuspeed --level 12345 off
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Aus   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus
[root@nagios-rzkb ~]# chkconfig cpuspeed on
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Aus   2:Ein   3:Ein   4:Ein   5:Ein   6:Aus
[root@nagios-rzkb ~]# chkconfig cpuspeed --level 12345 on
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Ein   2:Ein   3:Ein   4:Ein   5:Ein   6:Aus
[root@nagios-rzkb ~]# chkconfig cpuspeed off
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Ein   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus

I don't know if this behaviour is intended. It might make sense. But if this is
the case, it's not in the documentation.

Version-Release number of selected component (if applicable):
chkconfig-1.3.30.1-1

How reproducible:
Each time.

Steps to Reproduce:
See above.
  
Actual results:
[root@nagios-rzkb ~]# chkconfig cpuspeed off
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Ein   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus

Expected results:
[root@nagios-rzkb ~]# chkconfig cpuspeed off
[root@nagios-rzkb ~]# chkconfig cpuspeed --list
cpuspeed        0:Aus   1:Aus   2:Aus   3:Aus   4:Aus   5:Aus   6:Aus


Additional info:

Comment 1 Bill Nottingham 2008-02-15 15:45:18 UTC
From the man page:

       By default, the on and off options affect only runlevels 2, 3,  4,  and
       5,  while  reset and resetpriorities affects all of the runlevels.  The
       --level option may be used to specify which runlevels are affected.





Note You need to log in before you can comment on or make changes to this bug.