Bug 432953 - [RFE] repoquery should output "-i" before "--changelog"
[RFE] repoquery should output "-i" before "--changelog"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 07:28 EST by Bill Crawford
Modified: 2008-03-13 11:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 11:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2008-02-15 07:28:23 EST
Description of problem:
When using repoquery to do "-qi --changelog" the changelog is printed out 
*before* the info, and also with no visual indication to separate it from the 
previous output (i.e. the "info" output of the previous package). This is very 
confusing, e.g.:

Name        : xorg-x11-server-Xorg
Version     : 1.3.0.0
Release     : 42.fc8
...
Description :
X.org X11 is an open source implementation of the X Window System.  It
provides the basic low level functionality which full fledged
graphical user interfaces (GUIs) such as GNOME and KDE are designed
upon.
* Thu Jan 24 2008 Than Ngo <than@redhat.com> 3.3.8b-2
- add add LICENSE.GPL2/GPL3
...

The latter is the start of changelog data for *qt* not Xorg ...

Version-Release number of selected component (if applicable):
1.1.11-1.fc8


How reproducible:
repoquery --repoid=updates-testing -qi --changelog qt vim-enhanced 
xorg-x11-server-Xorg ConsoleKit | less

Steps to Reproduce:
1. Run command as above
2. Try to read the output
3. Get confused.
  
Actual results:
As above.

Expected results:
Output in expected order (info before changelog, especially since the -qi 
comes before the --changelog on the command line).

Additional info:
It would be even nicer if the packages were process in the order I asked for 
them. Maybe a pony.
Comment 1 Seth Vidal 2008-03-13 11:39:11 EDT
Excellent. This is fixed in upstream and will be out in yum-utils 1.1.12.

Thanks

Note You need to log in before you can comment on or make changes to this bug.