Bug 432977 - Error in /etc/init.d/irqbalance results in potential misconfiguration and screen garbage
Error in /etc/init.d/irqbalance results in potential misconfiguration and scr...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: irqbalance (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
: Regression
: 437989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 11:03 EST by James Laska
Modified: 2013-09-02 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0419
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-02-15 11:03:32 EST
Description of problem:

Starting system logger: [  OK  ]
Starting kernel logger: [  OK  ]
export CONSOLE="/dev/console"
export HOME="/"
export INIT_VERSION="sysvinit-2.86"
export LANG="en_US.UTF-8"
export OLDPWD
export PATH="/sbin:/usr/sbin:/bin:/usr/bin"
export PREVLEVEL="N"
export PWD="/"
export RUNLEVEL="5"
export SELINUX_INIT="YES"
export SHLVL="2"
export TERM="linux"
export previous="N"
export runlevel="5"
export CONSOLE="/dev/console"
export HOME="/"
export INIT_VERSION="sysvinit-2.86"
export LANG="en_US.UTF-8"
export OLDPWD
export PATH="/sbin:/usr/sbin:/bin:/usr/bin"
export PREVLEVEL="N"
export PWD="/"
export RUNLEVEL="5"
export SELINUX_INIT="YES"
export SHLVL="2"
export TERM="linux"
export previous="N"
export runlevel="5"
export CONSOLE="/dev/console"
export HOME="/"
export INIT_VERSION="sysvinit-2.86"
export LANG="en_US.UTF-8"
export OLDPWD
export PATH="/sbin:/usr/sbin:/bin:/usr/bin"
export PREVLEVEL="N"
export PWD="/"
export RUNLEVEL="5"
export SELINUX_INIT="YES"
export SHLVL="2"
export TERM="linux"
export previous="N"
export runlevel="5"
Starting irqbalance: [  OK  ]
S

Version-Release number of selected component (if applicable):

RHEL5.2-Server-20080212.0/ppc (irqbalance-0.55-8)

How reproducible:
100%

Steps to Reproduce:
1. Boot system with irqbalance enabled (default)
  
Actual results:


Expected results:


Additional info:

The following fix resolves the issue.

--- /etc/sysconfig/irqbalance   2007-12-03 13:55:51.000000000 -0500
+++ /tmp/irqbalance     2008-02-15 10:58:03.000000000 -0500
@@ -6,7 +6,7 @@
 #    after starting, wait for a minute, then look at the interrupt
 #    load and balance it once; after balancing exit and do not change
 #    it again.
-ONESHOT=
+#ONESHOT=
 
 #
 # IRQ_AFFINITY_MASK
--- /tmp/irqbalance.init        2008-02-15 10:59:05.000000000 -0500
+++ /etc/init.d/irqbalance      2008-02-15 11:01:53.000000000 -0500
@@ -43,9 +43,9 @@
 RETVAL=0
 
 start() {
-       export $ONESHOT
-       export $IRQBALANCE_BANNED_INTERRUPTS
-       export $IRQBALANCE_BANNED_CPUS
+       export ONESHOT=$ONESHOT
+       export IRQBALANCE_BANNED_INTERRUPTS=$IRQBALANCE_BANNED_INTERRUPTS
+       export IRQBALANCE_BANNED_CPUS=$IRQBALANCE_BANNED_CPUS
         if [ -n "$ONESHOT" -a -f /var/lock/irqbalance ]; then
                 exit 0
         fi
Comment 2 Neil Horman 2008-02-15 11:23:13 EST
James, not sure I see what the problem is here, can you elaborate a bit please?
Thanks!
Comment 3 Nate Straz 2008-02-15 11:58:45 EST
If any of the variables in the export statements aren't set, export will instead
print out all exported variables.  The openning comment show the extra output
generated when none of the variables are set.
Comment 4 Neil Horman 2008-02-18 11:40:56 EST
ahh, my bad, I see what you're saying here.  Thanks, I'll get this in ASAP
Comment 7 James Laska 2008-02-26 13:40:06 EST
A fix for this issue is *not* present in the current beta RC
(irqbalance-0.55-8.el5).  

This issue is presently tagged against the target milestones of GA.  Will retest
post-beta.
Comment 8 Neil Horman 2008-03-18 12:50:37 EDT
*** Bug 437989 has been marked as a duplicate of this bug. ***
Comment 9 Neil Horman 2008-04-09 13:41:05 EDT
This is fixed in -9.el5
Comment 11 errata-xmlrpc 2008-05-21 13:21:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0419.html

Note You need to log in before you can comment on or make changes to this bug.