Bug 432994 - lvm.sh 'File descriptor X left open' messages
lvm.sh 'File descriptor X left open' messages
Status: CLOSED DUPLICATE of bug 431713
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
:
Depends On: 431713
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 11:54 EST by Lon Hohberger
Modified: 2010-01-27 13:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 13:07:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2008-02-15 11:54:37 EST
Description of problem:

When running rg_test, you get strange messages from lvm.sh:

[root@grant-03 ~]# rg_test test /etc/cluster/cluster.conf stop service halvm
Running in test mode.
Stopping halvm...
<debug>  stop: Could not match /dev/GRANT/ha2 with a real device
<debug>  fs (isMounted): Could not match /dev/GRANT/ha2 with a real device
<info>   /dev/GRANT/ha2 is not mounted
<debug>  stop: Could not match /dev/GRANT/ha1 with a real device
<debug>  fs (isMounted): Could not match /dev/GRANT/ha1 with a real device
<info>   /dev/GRANT/ha1 is not mounted
File descriptor 4 left open
File descriptor 4 left open
  volume_list=["VolGroup00", "@grant-03"]
File descriptor 4 left open
  0 logical volume(s) in volume group "GRANT" now active
File descriptor 4 left open
File descriptor 4 left open
File descriptor 4 left open
Stop of halvm complete

Version-Release number of selected component (if applicable): rgmanager-2.0.36-1.el5

How reproducible: 100%

I do not think this is critical at all.  I saw it while trying to track down
another issue fore Corey.
Comment 1 Jonathan Earl Brassow 2008-02-15 12:03:39 EST
volume_list=["VolGroup00", "@grant-03"]  should not be printed.  There is an
update waiting for 5.3 that changes this section of code...  This issue may go
away when that one (bug #431713) is fixed.
Comment 2 Lon Hohberger 2010-01-27 13:07:56 EST

*** This bug has been marked as a duplicate of bug 431713 ***

Note You need to log in before you can comment on or make changes to this bug.