Bug 433006 - [RFE] yumdownloader should allow --enablerepo option
[RFE] yumdownloader should allow --enablerepo option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 12:24 EST by Ian Malone
Modified: 2008-02-16 05:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 12:39:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Malone 2008-02-15 12:24:54 EST
Description of problem:
yumdownloader doesn't appear to use the enablerepo option,
if you want to use it to download source files you must
enable those repositories in /etc/yum.repos.d/

Version-Release number of selected component (if applicable):
yum-utils-1.1.11-1.fc8

How reproducible:
100%

Steps to Reproduce:
1. Install yum-utils
2. Check the fedora-source entry in /etc/yum.repos.d/fedora.repo has enabled=0
3. $ yumdownloader --source --enablerepo fedora-source pdfedit
  
Actual results:
"Nothing to download"

Expected results:
Downloads pdfedit source package.

Additional info:
Otherwise getting source packages requires I always have the
-source repos enabled all the time, which slows down normal
updates.
Comment 1 Seth Vidal 2008-02-15 12:39:06 EST
yumdownloader --source  pkgname

works just fine w/o using --enablerepo or --disablerepo for me.

have you tried that?

also yumdownloader supports --enablerepo and --disablerepo

see yumdownloader --help

Comment 2 Ian Malone 2008-02-15 13:29:12 EST
This appears to work now: it previously didn't running as a normal user. There
was a complaint about not being able to find a directory: I assume that not
having the repository enabled the repo data hadn't been downloaded.

--enablerepo: it seems man yumdownloader does not list many of the options that
yumdownloader --help does.  --enablerepo is listed by --help 

yumdownloader --source --enablerepo fedora-source pdfedit
still does not work while
yumdownloader --source pdfedit
It seems this is because the source for the current package is in
updates-source.  If --source automatically includes -source repos and
--enablerepo overrides that then this needs to be mentioned somewhere.
Comment 3 James Antill 2008-02-15 13:38:44 EST
 Pasting that exact command in above, does exactly the right thing. Adding
--urls gives me: pdfedit-0.3.2-2.fc8.src.rpm which is what "yum list" says is
the current version (and isn't in the update repo).

> There was a complaint about not being able to find a directory: I assume
> that not having the repository enabled the repo data hadn't been downloaded.

 Can you find the exact error message?

 From a quick look the only candidate I can see is: /var/cache/yum is needed for
.gpgkeyschecked.yum ... and I'm not even sure that'd be needed for downloading
source.
Comment 4 Ian Malone 2008-02-16 05:12:42 EST
>> There was a complaint about not being able to find a directory: I assume
>> that not having the repository enabled the repo data hadn't been downloaded.

> Can you find the exact error message?

Unfortunately cannot reproduce that one.  Now I know it should work will look
out for it in future, thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.