Bug 433040 - sosreports are too large, due to /var/log/httpd
sosreports are too large, due to /var/log/httpd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Stokes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 15:34 EST by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, sos reports included the contents of /var/log/httpd. This could make the reports very long, sometimes over 300 MB. Because the information contained in /var/log/httpd is relevant to few troubleshooting cases, sos no longer obtains it. If necessary, the contents of /var/log/httpd can still be obtained by using the apache sos plugin.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Guy Streeter 2008-02-15 15:34:15 EST
/var/log/httpd seem to always have a great deal of information in it, which is
almost always not relevant to a trouble report. We are seeing sosreports in
excess of 300 MB from some customers.

I think sos should not gather the data under /var/log/httpd, at least not by
default.
Comment 1 Alasdair Kergon 2008-02-15 19:50:48 EST
and/or perhaps a file size limit option, where it'll only grab the last X MB of
any file larger than X
Comment 3 RHEL Product and Program Management 2008-07-28 12:21:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2008-10-27 14:23:59 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 14 Ruediger Landmann 2009-09-02 01:23:48 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Previously, sos reports included the contents of /var/log/httpd. This could make the reports very long, sometimes over 300 MB. Because the information contained in /var/log/httpd is relevant to few troubleshooting cases, sos no longer obtains it. If necessary, the contents of /var/log/httpd can still be obtained by using the apache sos plugin.
Comment 15 errata-xmlrpc 2009-09-02 03:29:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1418.html

Note You need to log in before you can comment on or make changes to this bug.