Bug 433083 - g-wrap should use system libffi
g-wrap should use system libffi
Product: Fedora
Classification: Fedora
Component: g-wrap (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
: 474271 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-02-15 20:19 EST by Anthony Green
Modified: 2008-12-27 22:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-12-27 22:26:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2008-02-15 20:19:16 EST
Description of problem:
libffi was recently accepted into Fedora.  I've pushed it into rawhide and F-8.
g-wrap should build against this version of libffi.
Simply att `pkgconfig libffi --cflags` to the CFLAGS definition and it should
work (I tried this).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Bug Zapper 2008-05-14 01:13:38 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 2 Michel Alexandre Salim 2008-12-26 12:38:57 EST
*** Bug 474271 has been marked as a duplicate of this bug. ***
Comment 3 Michel Alexandre Salim 2008-12-26 12:46:01 EST
libffi provides libffi.so.5, whereas at least one dependent of g-wrap, guile-gnome-platform, depends on the libffi.so.4 currently shipped with g-wrap.

Xavier has not replied to this bug, so it seems that the safe option would be to push a new g-wrap package that uses the system libffi to Rawhide, rebuild guile-gnome-platform against it, and then we can consider pushing it back to F-10 if there is no problem.
Comment 4 Michel Alexandre Salim 2008-12-27 22:26:22 EST
Updated g-wrap and guile-gnome-platform built for Rawhide.

Note You need to log in before you can comment on or make changes to this bug.