Bug 433103 - invalid link on configuration channel file details
invalid link on configuration channel file details
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
501
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: Triaged
Depends On:
Blocks: 462714 479461
  Show dependency treegraph
 
Reported: 2008-02-16 06:35 EST by Kurt Keller
Modified: 2011-10-07 10:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-07 10:01:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Keller 2008-02-16 06:35:07 EST
Description of problem:

When displaying the details of a file in a configuration channel,
in the field for 'File Details' there is a 'Click here for more
information' link. Following this link to the reference manual
results in a 'page not found' error.

Version-Release number of selected component (if applicable):

rhn-satellite-config-5.0.0-5
rhn-satellite-schema-5.0.0-29
rhns-satellite-tools-5.0.1-10
rhn-satellite-admin-5.0.0-1

How reproducible:


Steps to Reproduce:
1. create a configuration channel
2. add a file to the configuration channel
3. go to the details tab of the created file item and click
   on the link in 'Click here for more information...'
  
Actual results:

page not found

Expected results:

Should link to a valid page in the reference manual.

Additional info:
Comment 1 Brandon Perkins 2009-02-10 13:41:48 EST
This may already be fixed, throwing on sat530-qa-backlog to check.
Comment 2 Corey Welton 2009-02-28 11:36:39 EST
Fails QA.

Page Not Found

The page you requested, /rhn/help/reference/en/s1-sm-configuration.jsp, was not found.

   1. If you typed this address into your browser, double-check the spelling and capitalization. The address you are copying may also be outdated.
   2. If you followed a link to reach '/rhn/help/reference/en/s1-sm-configuration.jsp,' the link may be incorrect or outdated. Click on the back button in your browser to try a different link, or use the top (or left) navigation bars to find the page you are looking for.
   3. If you used a bookmark to reach '/rhn/help/reference/en/s1-sm-configuration.jsp,' the page may have moved to a different location since the bookmark was created. Use the top (or left) navigation bars to find the page you are looking for, and if you find the document be sure to update your bookmark.
   4. If you feel you've reached this page in error, please contact us with details of how you received this message.
Comment 3 Shannon Hughes 2009-03-02 08:41:35 EST
i don't recall fixing this. moving to assigned state.
Comment 4 Clifford Perry 2009-03-30 11:53:36 EDT
Moving to canfix. I will not block release for this.
Comment 7 Jan Pazdziora 2011-02-02 11:10:27 EST
On Satellite 5.4.0, the link points to /rhn/help/reference/en-US/s1-sm-configuration.jsp which contains

7.7. Configuration
This tab is the portal to managing your configuration channels and files, whether they are centrally managed or limited to a single system. You must be a Configuration Administrator or an Satellite Administrator to see the Configuration tab. In addition, you must have at least one Provisioning entitlement, or the tab does not appear. 
[...]

We can close this CURRENTRELEASE.
Comment 8 Miroslav Suchý 2011-10-07 10:01:19 EDT
I do confirm that it works in current release.

Note You need to log in before you can comment on or make changes to this bug.