Bug 433111 - Broken dependency
Broken dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eggdrop (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 08:28 EST by Michael Schwendt
Modified: 2008-04-29 16:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.6.19-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 16:51:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (470 bytes, patch)
2008-02-18 06:13 EST, Adam Tkac
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2008-02-16 08:28:15 EST
eggdrop-1.6.18-14.fc8.i386  requires  libdns.so.40
Comment 1 Robert Scheck 2008-02-16 09:01:39 EST
Michael, https://admin.fedoraproject.org/updates/F8/FEDORA-2008-1622 only 
affects this. And bind-9.5.0-25.b2.fc8 is not yet in stable. I'm even trying
to avoid getting this bind update into Fedora, because it breaks everything
depending on libdns.so within a Fedora release series.
Comment 2 Adam Tkac 2008-02-18 06:13:20 EST
eggdrop is only one package which depends on libdns.so and reason for such
dependency is weird. It uses libdns for gethostbyname function which is not part
of libdns library but libc library (libdns is linked against libc so this
works). Linking eggdrop against libdns is bad idea and is not needed. Correct
linkage is against libc (or possibly against libbind but #include directives in
sources should be changed appropriately). Proposed patch is attached and
dependency on bind-{libs,devel} will be dropped. Yes, libdns bump in stable
release is not the best but it contains many bugfixes which also needs some ABI
changes and I don't want waste time with creating old api/abi compatibility
patch. Would it be possible patch eggdrop (which is correct solution)?
Comment 3 Adam Tkac 2008-02-18 06:13:58 EST
Created attachment 295158 [details]
proposed patch
Comment 4 Robert Scheck 2008-02-25 16:06:11 EST
http://koji.fedoraproject.org/packages/eggdrop/1.6.18/16.fc8/i386/eggdrop-
1.6.18-16.fc8.i386.rpm -- Michael, can you please let me know, whether this
package is working for you? If yes, I'll push an official update for it.
Comment 5 Fedora Update System 2008-03-09 09:15:08 EDT
eggdrop-1.6.18-16.fc7 has been submitted as an update for Fedora 7
Comment 6 Fedora Update System 2008-03-09 09:15:10 EDT
eggdrop-1.6.18-16.fc8 has been submitted as an update for Fedora 8
Comment 7 Robert Scheck 2008-03-09 09:16:09 EDT
Michael, ping?
Comment 8 Michael Schwendt 2008-03-09 13:20:36 EDT
Running depclosure checks on anything other than the public
repositories is beyond my time. You should be able to verify
an update yourself, please.
Comment 9 Robert Scheck 2008-03-09 13:27:00 EDT
a) This package was submitted to testing
b) You opened a bug report, because you cared about this. So if you don't
   care about a fix, please do not submit another bug report
c) It is not only a dependency fix, because resolving behaviour changed
Comment 10 Michael Schwendt 2008-03-09 15:12:23 EDT
a) There is no update in the repos yet, and bodhi confirms that:

Status:  	pending
Submitted:  	2008-03-09 13:15:20   <-- (!)
https://admin.fedoraproject.org/updates/F8/pending/eggdrop-1.6.18-16.fc8

b) I report broken dependencies in a semi-automated way as
they are found. You would be the first to not appreciate such
an early-warning system.

c) Verifying a feature-change is beyond the scope of this bug
report. *You* can verify whether this particular ticket can be closed.
For verifying the libdns->libc change, the test-update can stay in
updates-testing for some time.
Comment 11 Adam Tkac 2008-03-10 07:06:03 EDT
(In reply to comment #9)

> c) It is not only a dependency fix, because resolving behaviour changed
Resolving behavior is same as I wrote in comment #2 (nothing is used from
libdns, all is and was used from libc).

Only one thing which was changed is "checking for gethostbyname in -ldns... no"
line from configure so macro HAVE_LIBDNS is not defined in newer version. It
doesn't matter because it is never used in source code so you can put update
directly to stable. Also please tell this problem to upstream because it should
be fixed. I think this check will be simply dropped because gethostbyname calls
are not protected by #ifdef so it really doesn't make sence check existency of
it in some library.
Comment 12 Fedora Update System 2008-03-13 03:42:11 EDT
eggdrop-1.6.18-16.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eggdrop'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2405
Comment 13 Fedora Update System 2008-04-22 14:39:35 EDT
eggdrop-1.6.19-1.fc8 has been submitted as an update for Fedora 8
Comment 14 Fedora Update System 2008-04-22 14:39:47 EDT
eggdrop-1.6.19-1.fc7 has been submitted as an update for Fedora 7
Comment 15 Fedora Update System 2008-04-29 16:51:25 EDT
eggdrop-1.6.19-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-04-29 16:59:47 EDT
eggdrop-1.6.19-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.