Bug 433124 - Broken multi-lib dependency [with updates-testing]
Broken multi-lib dependency [with updates-testing]
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: codeblocks (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 11:30 EST by Michael Schwendt
Modified: 2008-03-03 13:24 EST (History)
0 users

See Also:
Fixed In Version: 1.0-0.30.20080211svn4872.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 13:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2008-02-16 11:30:07 EST
source rpm: codeblocks-1.0-0.27.20070828svn4413.fc8.src.rpm
package: codeblocks-contrib - 1.0-0.27.20070828svn4413.fc8.i386 from fedora-8-x86_64
  unresolved deps: 
     codeblocks = 0:1.0-0.27.20070828svn4413.fc8
Comment 1 Dan Horák 2008-02-17 05:53:48 EST
this is a really old version, should be fixed in 
codeblocks-1.0-0.28.20071210svn4719
codeblocks-contrib was split into codeblocks-contrib and codeblocks-contrib-libs
Comment 2 Michael Schwendt 2008-02-17 19:55:30 EST
There is no fix.

Due to the post-F8 split of your packages, none of your
updates replaces the old codeblocks-contrib.i386 package in
the x86_64 repo. It remains broken. codeblocks-contrib.i386
no longer is shipped for x86_64 automatically.
Comment 3 Dan Horák 2008-02-18 04:47:25 EST
OK, now I understand, where the problem is. I missed to add Obsoletes: to the
...-libs subpackage.

I will then add Obsoletes: codeblocks-contrib < 1.0-0.28.20071210svn4719 (the
version where the split was done) to codeblocks-contrib-libs subpackage.
Comment 4 Fedora Update System 2008-02-21 12:46:40 EST
codeblocks-1.0-0.30.20080211svn4872.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-02-21 12:47:35 EST
codeblocks-1.0-0.30.20080211svn4872.fc7 has been submitted as an update for Fedora 7
Comment 6 Fedora Update System 2008-02-25 19:26:21 EST
codeblocks-1.0-0.30.20080211svn4872.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update codeblocks'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1979
Comment 7 Fedora Update System 2008-03-03 13:22:30 EST
codeblocks-1.0-0.30.20080211svn4872.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-03-03 13:23:57 EST
codeblocks-1.0-0.30.20080211svn4872.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.