Bug 433169 - Computer freezes up with "NVRM: Xid in /var/log/messages"
Computer freezes up with "NVRM: Xid in /var/log/messages"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 00:54 EST by Andrew D.
Modified: 2008-07-03 02:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 02:14:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D. 2008-02-17 00:54:02 EST
Description of problem:

To be honest I'm not sure what sort of problem this classifies as but I thought
I'd post it here because it is the first time I've observed this and the only
thing I've updated in the past 24hrs is the kernel. I had a computer freeze up
on me. The mouse and keyboard wouldn't respond and I couldn't log into it via
ssh remotely. I had to do a hard reboot. The following message appeared in
/var/log/messages at about the time of the problem:

kernel: NVRM: Xid (0001:00): 6, PE001e 1818 3f800000 00109efc 00000000 00000000

I have an Nvidia6800GT AGP graphics card inside the box and am using the 169.09
drivers from Nvidia. I'm on a P4 hyperthreaded CPU. It certainly looks
Nvidia/kernel related and, as I mentioned, this only happened after the kernel
update.

Version-Release number of selected component (if applicable):
kernel-2.6.18-53.1.13.el5

How reproducible:
It has only happened once but shortly after the kernel update.


Steps to Reproduce:
1. Upgrade to kernel 2.6.18-53.1.13.el5
2. At some point computer freezes, requiring hard reboot
3. /var/log/messages shows "kernel: NVRM: Xid (0001:00): 6, PE001e 1818 3f800000
00109efc 00000000 00000000" with a time-stamp at the time of the crash.
  
Actual results:
System becomes totally unresponsive. You can't even log into it remotely via ssh.

Expected results:
System should not freeze up

Additional info:
Comment 1 Andrew D. 2008-02-18 14:47:06 EST
I rolled back to the previous kernel (2.6.18-53.1.6.el5) and the problem
occurred again the next day. The only difference was that this time there was no
message logged in /var/log/messages. This is strange since I've used that
kernel/video driver combination ever since the 53.1.6 kernel came out without
problems. It is possible that the problem might be hardware related. I recently
had my CPU fan replaced and noticed that the CPU was running hotter after the
replacement (mid 50's C on low load). It might be that the open-gl rss
screensavers are heating it up to the lockup point(?) Anyway, I've increased the
CPU fan speed in the BIOS and am now running at low-load temps around 41-42 C.
If the freeze up happens again I'll post it here with any more info I can find.
Comment 2 Prarit Bhargava 2008-05-08 08:59:32 EDT
Hi Andrew -- any updates?  Is this still occurring?

P.
Comment 3 Andrew D. 2008-05-25 17:44:15 EDT
Hi Prarit,  I'm sorry for not getting back to you sooner. I was just cleaning
out my inbox and noticed that I never addressed you question. 

I am no longer using the computer that experienced the crash due to a hardware
failure that occurred a few months ago. The reported crash happened a few times
on that machine but I am starting to suspect the issue was with the hardware,
not the operating system. My apologies for not getting back to you on this earlier.

Note You need to log in before you can comment on or make changes to this bug.