Bug 433181 - Yum can't resolve dependancies for Anjuta
Yum can't resolve dependancies for Anjuta
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 01:47 EST by Tim McConnell
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 11:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim McConnell 2008-02-17 01:47:53 EST
Description of problem:
Attempt to update system and receive error "Error: Missing Dependency:
libgbf-1.so.0 is needed by package anjuta
Error: Missing Dependency: libgbf-widgets-1.so.0 is needed by package anjuta" 

Version-Release number of selected component (if applicable):
3.2.8

How reproducible: run yum update 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Output from yum update command: 
Loading "protect-packages" plugin
Loading "merge-conf" plugin
Loading "kernel-module" plugin
Loading "priorities" plugin
Loading "protectbase" plugin
Loading "presto" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "fedorakmod" plugin
Loading "fastestmirror" plugin
Loading "allowdowngrade" plugin
Loading "tsflags" plugin
Setting up Presto
livna-development-debugin 100% |=========================| 1.9 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
livna-debuginfo           100% |=========================| 1.9 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
updates-debuginfo         100% |=========================| 1.9 kB    00:00     
fedora-debuginfo          100% |=========================| 1.9 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
Reading Presto metadata in from local files
Loading mirror speeds from cached hostfile
 * livna-development-debuginfo: mirrors.tummy.com
 * livna: mirrors.tummy.com
 * livna-debuginfo: mirrors.tummy.com
 * fedora: mirrors.usu.edu
 * adobe-linux-i386: linuxdownload.adobe.com
 * updates-debuginfo: mirrors.usu.edu
 * fedora-debuginfo: mirrors.usu.edu
 * updates: mirrors.usu.edu
primary.sqlite.bz2        100% |=========================|  42 kB    00:03     
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/development/i386/debug/repodata/primary.sqlite.bz2:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2        100% |=========================|  42 kB    00:00     
0 packages excluded due to repository protections
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
--> Processing Dependency: libgbf-1.so.0 for package: anjuta
--> Processing Dependency: libgbf-widgets-1.so.0 for package: anjuta
---> Package gnome-python2-extras.i386 0:2.14.3-8.fc7 set to be updated
---> Package devhelp.i386 0:0.13-13.fc7 set to be updated
---> Package httpd.i386 0:2.2.8-1.fc7 set to be updated
---> Package gimp.i386 2:2.4.4-1.fc7 set to be updated
---> Package gnome-build.i386 0:0.2.1-2.fc7 set to be updated
---> Package gnome-python2-gtkhtml2.i386 0:2.14.3-8.fc7 set to be updated
---> Package tomcat5.i386 0:5.5.26-1jpp.2.fc7 set to be updated
---> Package dovecot.i386 0:1.0.10-17.fc7 set to be updated
---> Package yelp.i386 0:2.18.1-9.fc7 set to be updated
---> Package gnome-python2-libegg.i386 0:2.14.3-8.fc7 set to be updated
filelists.sqlite.bz2      100% |=========================| 111 kB    00:00     
--> Finished Dependency Resolution
Error: Missing Dependency: libgbf-1.so.0 is needed by package anjuta
Error: Missing Dependency: libgbf-widgets-1.so.0 is needed by package anjuta
Comment 1 Burnie West 2008-02-21 08:23:24 EST
With the help of FedoraForum user Hlingler, After several --exclude tries, I
completed an update by excluding gnome-build.

But --exclude=gnome-build by itself was not enough.

For some reason even --exclude=gnome-build --exclude anjuta* did not work; it
actually required --exclude=gnome-build --exclude=anjuta --exclude=anjuta-devel
--exclude=anjuta-doc.

burnie
Comment 2 Seth Vidal 2008-02-21 11:03:30 EST
Not sure how this is a yum bug. File it aga inst the associated packages, please.

Note You need to log in before you can comment on or make changes to this bug.