Bug 433261 - mod_dav_svn doesn't installed
mod_dav_svn doesn't installed
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 02:34 EST by Edward
Modified: 2008-05-28 15:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward 2008-02-18 02:34:27 EST
Description of problem:

Packege Manager gave an error

Component: pirut
Summary: TBa5ad18b6 transactioninfo.py:523:setAsDep:MemoryError

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in _apply
    output = self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 798, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 537, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 574, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 713, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 787, in
_resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 845, in
_checkInstall
    member.setAsDep(txmbr.po)
  File "/usr/lib/python2.5/site-packages/yum/transactioninfo.py", line 523, in
setAsDep
    self.relatedto.append((po.pkgtup, 'dependson'))
MemoryError

Local variables in innermost frame:
self: nspr.i386 0-4.7-1.fc9 - u
po: rhythmbox - 0.11.4-7.fc9.i386



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. I'm just trying to install mod_dav_svn module. (frjm search list in Package
Manager
2.
3.
  
Actual results:
Package Manager tryed to resolv dependencis for a long time, and then crushed.

Expected results:


Additional info:
Comment 1 Jeremy Katz 2008-02-20 18:47:04 EST
What versions of yum and pirut do you have installed?
Comment 2 Edward 2008-02-21 06:15:46 EST
thanks. Sorry I dsn't remember version, I tryed many ones... from Fedora 8 & 9.
Problem already solved by installing manually of version of mod_dav*.RPM from 
rpmfind.
What about yum, Pakage Manager or yumex, not one hav abilities to suggest ANY 
kind of dessision after "unresolved dependensies" ussues.... :-( So sad.
May be I must to change pakage system to APT ?!?!? Or Any other suggestions?

Note You need to log in before you can comment on or make changes to this bug.