Bug 433279 - anaconda.intf.run(anaconda): TypeError: argument 4 must be string, not None
anaconda.intf.run(anaconda): TypeError: argument 4 must be string, not None
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 433361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 05:47 EST by Axel Thimm
Modified: 2008-02-19 17:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 16:25:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-02-18 05:47:54 EST
Description of problem:
The current rawhide installation bails out with

anaconda 11.4.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/isys.py", line 337, in mount
    rc = _isys.mount(fstype, device, location, flags)
  File "/usr/lib/anaconda/fsset.py", line 218, in mount
    readOnly = readOnly, bindMount = bindMount)
  File "/usr/lib/anaconda/fsset.py", line 2114, in mount
    instroot = chroot)
  File "/usr/lib/anaconda/fsset.py", line 1890, in mountFilesystems
    entry.mount(anaconda.rootPath, readOnly = readOnly)
  File "/usr/lib/anaconda/packages.py", line 169, in turnOnFilesystems
    anaconda.backend.skipFormatRoot)
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 132, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 231, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1278, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1425, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1435, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1198, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1067, in <module>
    anaconda.intf.run(anaconda)
TypeError: argument 4 must be string, not None


Version-Release number of selected component (if applicable):
Installer report 11.4.0.36

How reproducible:
always

Steps to Reproduce:
1.pxe boot into the rawhide installer
2.
3.
  
Actual results:
Immediately after downloading images/stage2.img the above exception occurs.

Expected results:


Additional info:
Comment 1 Chris Lumens 2008-02-18 15:56:31 EST
*** Bug 433361 has been marked as a duplicate of this bug. ***
Comment 2 Axel Thimm 2008-02-19 16:15:12 EST
I tried with the latest images that appeared today in rawhide and the problem is
still around anaconda.intf.run(anaconda):

anaconda 11.4.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/textw/timezone_text.py", line 68, in __call__
    (default, asUtc, asArc) = anaconda.id.timezone.getTimezoneInfo()
  File "/usr/lib/anaconda/text.py", line 674, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 1067, in <module>
    anaconda.intf.run(anaconda)
ValueError: need more than 2 values to unpack

Thanks!
Comment 3 Chris Lumens 2008-02-19 16:25:53 EST
This will be fixed in the NEXT build of anaconda, which has not yet made it into
a tree.  That will be anaconda-11.4.0.37.
Comment 4 Axel Thimm 2008-02-19 17:02:23 EST
OK, thanks!

BTW is there an even more rawhidish URL for guinea pigs to pick up images to
test like a p.r.c URL? I checked out http://people.redhat.com/clumens/, but
there "was nothing there" :)
Comment 5 Chris Lumens 2008-02-19 17:40:18 EST
There's always the anaconda gitweb page, from which you can extract the absolute
latest version of any file and make your own updates.img or RHupdates:

http://git.fedoraproject.org/git/?p=anaconda.git;a=summary

Note You need to log in before you can comment on or make changes to this bug.