Bug 433316 - gettext-0.17-2.fc9 java internal compiler error: Segmentation fault
gettext-0.17-2.fc9 java internal compiler error: Segmentation fault
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 11:43 EST by R P Herrold
Modified: 2008-07-04 02:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-04 02:54:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2008-02-18 11:43:07 EST
Description of problem:

building gettext-0.17-2.fc9.src.rpm, I obtain an error which requests I file
this bug here

Version-Release number of selected component (if applicable):

gettext-0.17-2.fc9.src.rpm,

How reproducible:

Build environment:


[herrold@dhcp-230 gettext]$ rpm -q `rpm -qf /usr/bin/gcj`
gcc-java-4.1.2-14.el5
[herrold@dhcp-230 gettext]$ rpm -q gcc automake autoconf libtool gettext glibc
gcc-4.1.2-14.el5
automake-1.10-5
autoconf-2.61-8
libtool-1.5.24-7orc
gettext-0.16.1-9orc
glibc-2.5-18.el5_1.1

Steps to Reproduce:

rpmbuild --rebuild gettext-0.17-2.fc9.src.rpm
  
Actual results:

completely reproducable


creating urlget
gcj -findirect-dispatch ./gnu/gettext/DumpResource.java
--main=gnu.gettext.DumpResource -o gnu.gettext.DumpResource
./gnu/gettext/DumpResource.java: In class 'gnu.gettext.DumpResource':
./gnu/gettext/DumpResource.java: In constructor
'(java.lang.String,java.lang.String)':
./gnu/gettext/DumpResource.java:220: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[4]: *** [gnu.gettext.DumpResource] Error 1
make[4]: Leaving directory
`/home/herrold/rpmbuild/BUILD/gettext-0.17/gettext-tools/src'
make[3]: *** [all] Error 2

I do not understand how to obtain the 'preprocessed source'  desired -- if asked
I shall do so

Expected results:

a clean rpmbuild, and resultant binary packages.

Additional info:

libtool-1.5.24-7orc was patched to permit building pre-gcc 4.3;
gettext-0.16.1-9orc was patched to omit the 4.3 version of
/usr/share/gettext/libintl.jar -- 

I will rebuild gettext-0.16.1-9orc with the jsr added to the package result set
in $files to see if that makes a difference.
Comment 1 R P Herrold 2008-02-18 12:51:22 EST
I build a later gettext with  /usr/share/gettext/libintl.jar present

[herrold@dhcp-230 gettext]$ rpm -q gettext
gettext-0.16.1-10orc
[herrold@dhcp-230 gettext]$ rpm -qf /usr/share/gettext/libintl.jar
gettext-0.16.1-10orc
[herrold@dhcp-230 gettext]$  

and retried, trying to bootstrap into the later gettext, but still end with the
same failure mode:

...
creating urlget
gcj -findirect-dispatch ./gnu/gettext/DumpResource.java
--main=gnu.gettext.DumpResource -o gnu.gettext.DumpResource
./gnu/gettext/DumpResource.java: In class 'gnu.gettext.DumpResource':
./gnu/gettext/DumpResource.java: In constructor
'(java.lang.String,java.lang.String)':
./gnu/gettext/DumpResource.java:220: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
make[4]: *** [gnu.gettext.DumpResource] Error 1
make[4]: Leaving directory
`/home/herrold/rpmbuild/BUILD/gettext-0.17/gettext-tools/src'
Comment 2 Jens Petersen 2008-02-18 22:23:37 EST
> [herrold@dhcp-230 gettext]$ rpm -q `rpm -qf /usr/bin/gcj`
> gcc-java-4.1.2-14.el5

Erm, why are you building F9 gettext with EL5 gcc?


> gcj -findirect-dispatch ./gnu/gettext/DumpResource.java
> --main=gnu.gettext.DumpResource -o gnu.gettext.DumpResource
> ./gnu/gettext/DumpResource.java: In class 'gnu.gettext.DumpResource':
> ./gnu/gettext/DumpResource.java: In constructor
> '(java.lang.String,java.lang.String)':
> ./gnu/gettext/DumpResource.java:220: internal compiler error: Segmentation fault
> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.

I think the intention is that ICE bugs be reported against gcc...
Comment 3 R P Herrold 2008-04-08 13:56:47 EDT
q: Erm, why are you building F9 gettext with EL5 gcc

A: As I noted I was trying the later rawhide version, in part as the build was 
failing already, and In eeded to get a bootstrap into the later version

gettext-0.16.1-9orc was patched to omit the 4.3 version of
/usr/share/gettext/libintl.jar

This to be able to bootstrap into a later gcc and java variant.

What is an ICE bug?   the acronym has no meaning to me, unfortunately.  Are you
sating the bug should be reassigned away from gettext?  That seems strange as a
suggestion, as that is the package asking for the filing of the report.


I am sorry I missed the request for bug update, but I must have missed your email.
Comment 4 Jens Petersen 2008-04-23 22:28:31 EDT
(In reply to comment #3)
> A: As I noted I was trying the later rawhide version, in part as the build was 
> failing already, and I needed to get a bootstrap into the later version

Ok, fair enough.

> What is an ICE bug?

ICE = internal compiler error (it is a GNU gcc acronym)

Could you try again with gettext-0.17-4.fc9 in current rawhide?
(it contain a fix for bug 433210 which might help here too).
Comment 5 R P Herrold 2008-05-12 15:44:43 EDT
testing
Comment 6 Bug Zapper 2008-05-14 01:15:47 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jens Petersen 2008-06-09 22:20:55 EDT
(In reply to comment #5)
> testing

How did the testing go?
Comment 8 Jens Petersen 2008-07-04 02:54:47 EDT
Closing this for lack of further information.
If the problem is still persisting and you can provide more info, please reopen.

Note You need to log in before you can comment on or make changes to this bug.