Bug 433416 - [bn, bn_IN] Phonetic input map Probhat requires updations for ZWNJ and ZWJ
[bn, bn_IN] Phonetic input map Probhat requires updations for ZWNJ and ZWJ
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: m17n-contrib (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 438778
  Show dependency treegraph
 
Reported: 2008-02-19 00:31 EST by Runa Bhattacharjee
Modified: 2013-03-03 21:21 EST (History)
4 users (show)

See Also:
Fixed In Version: m17n-contrib-bengali-1.1.6-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 04:05:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bn-probhat.mim file with new changes for ZWJ and ZWNJ position changes (2.99 KB, application/octet-stream)
2008-02-19 00:31 EST, Runa Bhattacharjee
no flags Details
patch (417 bytes, patch)
2008-02-26 04:05 EST, Parag Nemade
no flags Details | Diff
patch file for the above changes (431 bytes, patch)
2008-02-26 04:45 EST, Runa Bhattacharjee
no flags Details | Diff
complete bn-probhat file for the modifications - corrected (2.99 KB, application/octet-stream)
2008-02-26 04:46 EST, Runa Bhattacharjee
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12038 None None None Never

  None (edit)
Description Runa Bhattacharjee 2008-02-19 00:31:00 EST
Description of problem:

Bengali Probhat keymap needs updation, due to upstream modifications. Position
on ZWNJ and ZWJ have been modified.

Old keymapping:

ZERO WIDTH NON-JOINER (U+200C) at  '-' 
ZERO WIDTH JOINER (U+200D) at '+'

New keymapping:

ZERO WIDTH NON-JOINER (U+200C) at  '`'
ZERO WIDTH JOINER (U+200D) at '\'
ADDITION SIGN + = restored to '+' key
SUBTRACTION SIGN - = restored to '-' key



Additional info:

1. bn-probhat.mim file with the new changes attached

2. Screenshot for the new keymap:
http://www.bengalinux.org/images/probhat_layout.png
Comment 1 Runa Bhattacharjee 2008-02-19 00:31:00 EST
Created attachment 295260 [details]
bn-probhat.mim file with new changes for ZWJ and ZWNJ position changes
Comment 2 Parag Nemade 2008-02-26 04:01:01 EST
From attached file I see that 
ZERO WIDTH NON-JOINER (U+200C) at  '~' and NOT at '`' as per given in initial
comment.
Comment 3 Parag Nemade 2008-02-26 04:05:35 EST
Created attachment 295884 [details]
patch

Runa,
  Can you please confirm changes given in attached patch?
Comment 4 Runa Bhattacharjee 2008-02-26 04:45:06 EST
Parag, 
The above patch contains 200c in both ~ and `. Also,  my bad, the earlier .mim
file I submitted had the 200c and 200d in reverse positions. Kindly consider the
following as correct:

Old keymapping:

ZERO WIDTH NON-JOINER (U+200C) at  '-' 
ZERO WIDTH JOINER (U+200D) at '+'

New keymapping:

ZERO WIDTH JOINER (U+200D) at  '`'
ZERO WIDTH NON-JOINER (U+200C) at '\'
ADDITION SIGN + = restored to '+' key
SUBTRACTION SIGN - = restored to '-' key

Attachment of the patch submitted as well. Parag, can you please take a look as
well.

Thanks a lot and apologies once again for the confusion.

Runa
Comment 5 Runa Bhattacharjee 2008-02-26 04:45:50 EST
Created attachment 295886 [details]
patch file for the above changes
Comment 6 Runa Bhattacharjee 2008-02-26 04:46:45 EST
Created attachment 295887 [details]
complete bn-probhat file for the modifications - corrected
Comment 7 Parag Nemade 2008-02-26 06:09:12 EST
Runa,
  Thanks for patch. Will commit this patch in fedora cvs.
Comment 8 Runa Bhattacharjee 2008-02-26 06:40:19 EST
Thanks Parag. Please do ping me, Jamil or Sayamindu, in case any you need any
clarifications.
Comment 9 Parag Nemade 2008-02-28 22:12:28 EST
Built in m17n-contrib-bengali-1.1.6-2.fc9
Package is available in rawhide now.
Comment 10 Runa Bhattacharjee 2008-02-29 05:06:52 EST
Tested. Looks good. Thanks Parag.
Comment 11 Runa Bhattacharjee 2008-03-06 04:26:42 EST
This is a common phonetic keymap used by both the bn and bn_IN locales (both are
in Fedora and this is a Fedora bug. I suggest not to remove the [bn] tag. Adding
[bn] back. Thanks.
Comment 12 Bug Zapper 2008-05-14 01:16:25 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.