This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 433467 - Move /usr/share/asterisk to /var/lib/asterisk (it's dynamic content)
Move /usr/share/asterisk to /var/lib/asterisk (it's dynamic content)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 09:46 EST by Robert Scheck
Modified: 2008-02-19 10:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 10:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to relocate from /usr/share/asterisk to /var/lib/asterisk (4.96 KB, patch)
2008-02-19 09:56 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2008-02-19 09:46:29 EST
Description of problem:
Please move /usr/share/asterisk to /var/lib/asterisk, because it's dynamic 
content and every asterisk default seems to look in /var/lib/asterisk rather
in /usr/share/asterisk:

drwxr-xr-x    2 root    root  /usr/share/asterisk
drwxr-xr-x    2 root    root  /usr/share/asterisk/agi-bin
drwxr-xr-x    2 root    root  /usr/share/asterisk/images
-rw-r--r--    1 root    root  /usr/share/asterisk/images/asterisk-intro.jpg
drwxr-xr-x    2 root    root  /usr/share/asterisk/keys
-rw-r--r--    1 root    root  /usr/share/asterisk/keys/freeworlddialup.pub
-rw-r--r--    1 root    root  /usr/share/asterisk/keys/iaxtel.pub
drwxr-xr-x    2 root    root  /usr/share/asterisk/moh
drwxr-xr-x    2 root    root  /usr/share/asterisk/sounds
drwxr-xr-x    2 root    root  /usr/share/asterisk/static-http
-rw-r--r--    1 root    root  /usr/share/asterisk/static-http/ajamdemo.html
-rw-r--r--    1 root    root  /usr/share/asterisk/static-http/astman.css
-rw-r--r--    1 root    root  /usr/share/asterisk/static-http/astman.js
-rw-r--r--    1 root    root  /usr/share/asterisk/static-http/prototype.js

Version-Release number of selected component (if applicable):
asterisk-1.4.17-1.fc9

How reproducible:
Everytime, see above.

Actual results:
/usr/share/asterisk for dynamic content...

Expected results:
Move /usr/share/asterisk to /var/lib/asterisk, because it's dynamic content.

Additional info:
I'll attach a patch which solves the issue for me.
Comment 1 Robert Scheck 2008-02-19 09:56:48 EST
Created attachment 295292 [details]
Proposed patch to relocate from /usr/share/asterisk to /var/lib/asterisk
Comment 2 Jeffrey C. Ollie 2008-02-19 10:14:28 EST
I disagree - for me the data in astdatadir rarely changes, and when it does
change it's always something I've manually uploaded.  As far as I can see,
Asterisk itself never writes to astdatadir - writes always go to directories in
/var/lib/asterisk or /var/spool/asterisk.  While I agree that the common
practice may be different there's no reason to perpetuate that in Fedora.  This
will be especially true once I get around to locking Asterisk down with SELinux.

Note You need to log in before you can comment on or make changes to this bug.